Web   ·   Wiki   ·   Activities   ·   Blog   ·   Lists   ·   Chat   ·   Meeting   ·   Bugs   ·   Git   ·   Translate   ·   Archive   ·   People   ·   Donate
summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorIgnacio Rodríguez <ignacio@Ignacio-Magallanes.(none)>2012-10-26 14:50:08 (GMT)
committer Ignacio Rodríguez <ignacio@Ignacio-Magallanes.(none)>2012-10-26 14:50:08 (GMT)
commitdb0d08685410d174d7eab0fb875a8807f6cd01db (patch)
tree64794fdc1af45ee5ea111f1556b1ff96dea1a8b3 /setup.py
parent704742313a2c5a60e34510fca8d410c6384409b7 (diff)
Port finish, But I Need Summary!
Diffstat (limited to 'setup.py')
-rw-r--r--[-rwxr-xr-x]setup.py33
1 files changed, 3 insertions, 30 deletions
diff --git a/setup.py b/setup.py
index e5026ee..8a900da 100755..100644
--- a/setup.py
+++ b/setup.py
@@ -1,32 +1,5 @@
#!/usr/bin/env python
-import os
-import sys
+from sugar3.activity import bundlebuilder
-if len(sys.argv) > 1 and '--no-sugar' == sys.argv[1]:
- # Remove the argument from the stack so we don't cause problems
- # for distutils
- sys.argv.pop(1)
-
- import glob, os.path, string
- from distutils.core import setup
-
- DATA_FILES = [
- ('icons', glob.glob('icons/*')),
- ('images', glob.glob('images/*')),
- ('/usr/share/applications', ['turtleart.desktop'])
- ]
-
- setup (name = 'Turtle Art',
- description = "A LOGO-like tool for teaching programming",
- author = "Walter Bender",
- author_email = "walter.bender@gmail.com",
- version = '0.9.4',
- packages = ['TurtleArt'],
- scripts = ['turtleart'],
- data_files = DATA_FILES,
- )
-else:
- from sugar.activity import bundlebuilder
-
- if __name__ == "__main__":
- bundlebuilder.start()
+if __name__ == "__main__":
+ bundlebuilder.start()