Web   ·   Wiki   ·   Activities   ·   Blog   ·   Lists   ·   Chat   ·   Meeting   ·   Bugs   ·   Git   ·   Translate   ·   Archive   ·   People   ·   Donate
summaryrefslogtreecommitdiffstats
path: root/debian/cdbs/1/class/python-sugar.mk
diff options
context:
space:
mode:
authorJonas Smedegaard <dr@jones.dk>2008-08-16 20:05:23 (GMT)
committer Jonas Smedegaard <dr@jones.dk>2008-08-16 20:05:23 (GMT)
commite20b5d275e5afeac74be35fe0f73c30dfc70ffdb (patch)
tree9e1ad02f42ff22f3fda29907f5c0186ec0e7efe9 /debian/cdbs/1/class/python-sugar.mk
parent47b217562e9d1ff669a7a8250bca1d59130513cf (diff)
Update cdbs snippets, copyright-hints and dependencies.
* Update cdbs snippets: + Use new upstream-tarball.mk to implement get-orig-source target and more. + Fix python-sugar.mk to work with recent python-sugar-toolkit where MANIFEST files are ignored and an internal hardcoded exception list is used instead. Tighten build-dependency. + Relax copyright-check to only warn about its discoveries. See bug#486975 for more info. + Move dependency cleanup to new local snippet package-relations.mk. + Update copyright-check output to more closely match proposed new copyright file format. Update copyright-hints. + Update README.cdbs-tweaks. * Add DEB_MAINTAINER_MODE in debian/rules (thanks to Romain Beauxis). * Semi-auto-update debian/control to update dependencies: DEB_MAINTAINER_MODE=1 fakeroot debian/rules clean
Diffstat (limited to 'debian/cdbs/1/class/python-sugar.mk')
-rw-r--r--debian/cdbs/1/class/python-sugar.mk30
1 files changed, 4 insertions, 26 deletions
diff --git a/debian/cdbs/1/class/python-sugar.mk b/debian/cdbs/1/class/python-sugar.mk
index 889ca4d..b5fa58e 100644
--- a/debian/cdbs/1/class/python-sugar.mk
+++ b/debian/cdbs/1/class/python-sugar.mk
@@ -30,7 +30,7 @@ include debian/cdbs/1/class/python-vars.mk
include $(_cdbs_rules_path)/debhelper.mk$(_cdbs_makefile_suffix)
# Declare Build-Deps for packages using this file
-CDBS_BUILD_DEPENDS := $(CDBS_BUILD_DEPENDS), python-sugar, python-sugar-toolkit (>= 0.79.6-2~), unzip
+CDBS_BUILD_DEPENDS := $(CDBS_BUILD_DEPENDS), python-sugar, python-sugar-toolkit (>= 0.81.4-2~), unzip
# FIXME: Resolve DEB_PYTHON_PACKAGES in build targets only
ifeq (,$(cdbs_python_pkg_check)$(DEB_PYTHON_ARCH_PACKAGES))
ifneq (, $(cdbs_python_compile_version))
@@ -49,33 +49,15 @@ endif
DEB_PYTHON_SUGAR_PACKAGES = $(filter sugar-%-activity, $(DEB_PACKAGES))
-# Files or `find -name`-compatible search patterns to add to temp MANIFEST
-#DEB_PYTHON_SUGAR_MANIFEST = *.py *.po *.pot *.svg
-
-DEB_PYTHON_SUGAR_MANIFEST_REGEX =
-DEB_PYTHON_SUGAR_MANIFEST_IGNORE_REGEX = ^debian/.*
-
# TODO: Move this to buildvars.mk
cdbs_pkgsrcdir = $(if $(DEB_PKGSRCDIR_$(cdbs_curpkg)),$(DEB_PKGSRCDIR_$(cdbs_curpkg)),$(DEB_SRCDIR))
-cdbs_python_sugar_manifest_files_tmp = $(patsubst %,-or -name '%',$(DEB_PYTHON_SUGAR_MANIFEST))
-cdbs_python_sugar_manifest_files = $(wordlist 2, $(words $(cdbs_python_sugar_manifest_files_tmp)), $(cdbs_python_sugar_manifest_files_tmp))
-
-cdbs_python_sugar_automanifest = $(if $(DEB_PYTHON_SUGAR_MANIFEST_$(cdbs_curpkg)),$(DEB_PYTHON_SUGAR_MANIFEST_$(cdbs_curpkg)),$(DEB_PYTHON_SUGAR_MANIFEST))
-
pre-build::
mkdir -p debian/stamps-configure
-# FIXME: make these targets *not* run twice but respect stamps!
-$(patsubst %,configure/%,$(DEB_PYTHON_SUGAR_PACKAGES)) :: configure/%: debian/stamps-configure/%
-$(patsubst %,debian/stamps-configure/%,$(DEB_PYTHON_SUGAR_PACKAGES)) :: debian/stamps-configure/%:
- $(if $(cdbs_python_sugar_automanifest),i="$(cdbs_pkgsrcdir)/MANIFEST"; if [ -e "$$i" ] && [ ! -e "$$i.cdbs-orig" ]; then mv "$$i" "$$i.cdbs-orig"; fi)
- $(if $(cdbs_python_sugar_automanifest),cd "$(cdbs_pkgsrcdir)" && find * -type f $(if $(cdbs_python_sugar_manifest_files)$(DEB_PYTHON_SUGAR_MANIFEST_REGEX),'(' $(cdbs_python_sugar_manifest_files) $(if $(DEB_PYTHON_SUGAR_MANIFEST_REGEX),$(if $(cdbs_python_sugar_manifest_files),-or )-regex '$(DEB_PYTHON_SUGAR_MANIFEST_REGEX)') ')') $(if $(DEB_PYTHON_SUGAR_MANIFEST_IGNORE_REGEX),-not -regex '$(DEB_PYTHON_SUGAR_MANIFEST_IGNORE_REGEX))' > "$(cdbs_pkgsrcdir)/MANIFEST")
- touch $@
-
$(patsubst %,build/%,$(DEB_PYTHON_SUGAR_PACKAGES)) :: build/%:
for pythonver in $(cdbs_python_build_versions); do \
- /usr/bin/python$$ver $(cdbs_pkgsrcdir)/setup.py dist; \
+ /usr/bin/python$$ver $(cdbs_pkgsrcdir)/setup.py dist_xo; \
done
$(patsubst %,install/%,$(DEB_PYTHON_SUGAR_PACKAGES)) :: install/%:
@@ -95,19 +77,15 @@ clean:: $(patsubst %,cleanpythonsugar/%,$(DEB_PYTHON_SUGAR_PACKAGES))
ifeq (, $(cdbs_selected_pycompat))
echo "$(cdbs_pycompat)" >debian/pycompat
endif # use pycompat
- rm -rf debian/stamps-configure
$(patsubst %,cleanpythonsugar/%,$(DEB_PYTHON_SUGAR_PACKAGES)) :: cleanpythonsugar/% :
- for pythonver in $(cdbs_python_build_versions); do \
- /usr/bin/python$$ver $(cdbs_pkgsrcdir)/setup.py clean; \
- done
- find "$(cdbs_pkgsrcdir)" -maxdepth 1 -type f -name '*.xo' -exec rm -f '{}' ';'
+ -find "$(cdbs_pkgsrcdir)/dist" -maxdepth 1 -type f -name '*.xo' -exec rm -f '{}' ';'
+ -rmdir --ignore-fail-on-non-empty "$(cdbs_pkgsrcdir)/dist"
-IFS="`printf '\n'`" find "$(cdbs_pkgsrcdir)/locale" -type f \( -name '*.mo' -or -name 'activity.linfo' \) | while read path; do \
rm -f "$$path"; \
rmdir --ignore-fail-on-non-empty "`dirname "$$path"`"; \
done
-rmdir --ignore-fail-on-non-empty "$(cdbs_pkgsrcdir)/locale"
- $(if $(cdbs_python_sugar_automanifest),i="$(cdbs_pkgsrcdir)/MANIFEST"; if test -e "$$i.cdbs-orig"; then mv -f "$$i.cdbs-orig" "$$i"; fi)
## TODO: Drop this when DEB_PYTHON_PACKAGES is only resolved in build targets
pre-build clean::