Web   ·   Wiki   ·   Activities   ·   Blog   ·   Lists   ·   Chat   ·   Meeting   ·   Bugs   ·   Git   ·   Translate   ·   Archive   ·   People   ·   Donate
summaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules9
1 files changed, 7 insertions, 2 deletions
diff --git a/debian/rules b/debian/rules
index 49c47b9..8f19889 100755
--- a/debian/rules
+++ b/debian/rules
@@ -5,6 +5,11 @@
# NB! Local CDBS tweaks in use. More info in README.cdbs-tweaks
DEB_BUILDDIR = build
DEB_PYTHON_SYSTEM = pycentral
+ifneq (,$(DEB_MAINTAINER_MODE))
+ # Enable stuff not policy compliant (eg. unsuitable for build daemons)
+ DEB_COPYRIGHT_CHECK_STRICT = yes
+ DEB_AUTO_UPDATE_DEBIAN_CONTROL = yes
+endif
include debian/cdbs/1/rules/upstream-tarball.mk
include /usr/share/cdbs/1/rules/patchsys-quilt.mk
include debian/cdbs/1/rules/copyright-check.mk
@@ -29,5 +34,5 @@ pkg = python-olpc-datastore
# (temporarily disabled: python-sugar-toolkit is not yet in Debian)
#CDBS_BUILD_DEPENDS := $(CDBS_BUILD_DEPENDS), python-setuptools, python-dbus, python-gobject, python-sugar-toolkit
-# Merge duplicate build-dependencies
-CDBS_BUILD_DEPENDS := $(shell echo '$(CDBS_BUILD_DEPENDS)' | sed -e '/\bcdbs (>= 0.4.39)/ s/ *,* *\bcdbs (>= \(0.4.23-1.1\|0.4.27\)) *,* */, /g' -e 's/^ *, *//' -e 's/ *, *$$//')
+# Resolve, cleanup and apply CDBS-declared dependencies
+include debian/cdbs/1/rules/package-relations.mk