Web   ·   Wiki   ·   Activities   ·   Blog   ·   Lists   ·   Chat   ·   Meeting   ·   Bugs   ·   Git   ·   Translate   ·   Archive   ·   People   ·   Donate
summaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules23
1 files changed, 5 insertions, 18 deletions
diff --git a/debian/rules b/debian/rules
index 3a4fd4c..34b8561 100755
--- a/debian/rules
+++ b/debian/rules
@@ -3,34 +3,24 @@
# Copyright © 2008 Jonas Smedegaard <dr@jones.dk>
# NB! Local CDBS tweaks in use. More info in README.cdbs-tweaks
-DEB_AUTO_UPDATE_ACLOCAL = 1.10
-DEB_AUTO_UPDATE_AUTOMAKE = 1.10
-DEB_AUTO_UPDATE_AUTOCONF = 2.61
-DEB_AUTO_UPDATE_LIBTOOL = pre
-
DEB_BUILDDIR = build
DEB_PYTHON_SYSTEM = pycentral
+include debian/cdbs/1/rules/upstream-tarball.mk
include /usr/share/cdbs/1/rules/patchsys-quilt.mk
include debian/cdbs/1/rules/copyright-check.mk
include debian/cdbs/1/class/python-autotools.mk
include /usr/share/cdbs/1/rules/debhelper.mk
include debian/cdbs/1/rules/buildinfo.mk
+DEB_UPSTREAM_URL = http://dev.laptop.org/pub/sugar/sources/$(DEB_UPSTREAM_PACKAGE)
+DEB_UPSTREAM_TARBALL_EXTENSION = tar.bz2
+DEB_UPSTREAM_TARBALL_MD5 = be562779d3f5daa7fca9119b01da80d0
+
pkg = python-olpc-datastore
# Unittests temporarily disabled: python-sugar-toolkit is not yet in Debian
#DEB_MAKE_CHECK_TARGET = test
-# Workaround: can't pass --install to autotools through CDBS
-pre-build::
- [ -e configure ] || autoreconf -i
-
-# Cleanup automade files
-clean::
- rm -f aclocal.m4 compile config.guess config.sub configure depcomp install-sh ltmain.sh missing
- rm -f py-compile
- find -name Makefile.in -exec rm '{}' ';'
-
# Needed by upstream documentation build process
# (disabled: not yet integrated with main build routines)
#CDBS_BUILD_DEPENDS := $(CDBS_BUILD_DEPENDS), python-docutils, python-epydoc
@@ -39,9 +29,6 @@ clean::
# (temporarily disabled: python-sugar-toolkit is not yet in Debian)
#CDBS_BUILD_DEPENDS := $(CDBS_BUILD_DEPENDS), python-setuptools, python-dbus, python-gobject, python-sugar-toolkit
-# Replace virtual automake1.10 build-dependency with automake
-CDBS_BUILD_DEPENDS := $(shell echo '$(CDBS_BUILD_DEPENDS)' | sed -e 's/\bautomake1\.10\b/automake/')
-
# Merge duplicate build-dependencies
CDBS_BUILD_DEPENDS := $(shell echo '$(CDBS_BUILD_DEPENDS)' | sed -e '/\bcdbs (>= 0.4.27-1)/ s/ *,* *\bcdbs (>= \(0.4.23-1.1\)) *,* */, /g' -e 's/^ *, *//' -e 's/ *, *$$//')