Web   ·   Wiki   ·   Activities   ·   Blog   ·   Lists   ·   Chat   ·   Meeting   ·   Bugs   ·   Git   ·   Translate   ·   Archive   ·   People   ·   Donate
summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMarco Pesenti Gritti <marco@localhost.localdomain>2008-06-20 21:28:18 (GMT)
committer Marco Pesenti Gritti <marco@localhost.localdomain>2008-06-20 21:28:18 (GMT)
commit1b49f91a3eb89523a11d7b616ad189d7bb57eff6 (patch)
tree6038e4ea634ad4527b1941869ce2502298c187a3 /configure.ac
parent20f9a0fcd51e5edc7ea5c66fb655cd028319100d (diff)
Fix distcheck. Better way of figuring out libxul dir.v0.4.1
Release 0.4.1
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 2cd5928..4b3c2eb 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,4 +1,4 @@
-AC_INIT([hulahop],[0.4.0],[],[hulahop])
+AC_INIT([hulahop],[0.4.1],[],[hulahop])
AC_PREREQ([2.59])
@@ -26,7 +26,7 @@ PKG_CHECK_MODULES([LIBXUL],[libxul])
# FIXME To be able to use pyxpcom we currently need
# to link to xpcom at build time. Which involves various hacks.
LIBXUL_SDK_DIR=`$PKG_CONFIG --variable=sdkdir libxul`
-LIBXUL_DIR=`echo $LIBXUL_SDK_DIR | sed -e 's/-devel//'`
+LIBXUL_DIR="`dirname $LIBXUL_SDK_DIR`/xulrunner-`$PKG_CONFIG --modversion libxul`"
LIBXUL_LIBS="$LIBXUL_LIBS -L$LIBXUL_DIR -lpyxpcom"
LIBXUL_CFLAGS=`$PKG_CONFIG --cflags --define-variable=includetype=unstable libxul`