Web   ·   Wiki   ·   Activities   ·   Blog   ·   Lists   ·   Chat   ·   Meeting   ·   Bugs   ·   Git   ·   Translate   ·   Archive   ·   People   ·   Donate
summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorSimon Schampijer <erikos@localhost.localdomain>2008-07-29 08:04:05 (GMT)
committer Simon Schampijer <erikos@localhost.localdomain>2008-07-29 08:04:05 (GMT)
commit80820f45ae5147269565aa1e05057031ee621070 (patch)
tree9c2ec9a6d29af471585c6b58a3b4b633e387d570 /configure.ac
parent6a904c919eabdd78f6aa9ebce2107e993a5f8131 (diff)
Setup a nsXULAppInfo service and register #7530 (tomeu)
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac16
1 files changed, 15 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index e9b6b22..e2f2f67 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,10 +1,20 @@
-AC_INIT([hulahop],[0.4.2],[],[hulahop])
+m4_define([hulahop_build_id],[2008072400]) # FIXME: when should we update this?
+m4_define([hulahop_version],[0.4.2])
+
+AC_INIT([hulahop],[hulahop_version],[],[hulahop])
+
+AC_SUBST([HULAHOP_VERSION],[hulahop_version])
+AC_SUBST([HULAHOP_BUILD_ID],[hulahop_build_id])
AC_PREREQ([2.59])
AC_CONFIG_MACRO_DIR([m4])
AC_CONFIG_SRCDIR([configure.ac])
+AC_CANONICAL_HOST
+AC_SUBST([HULAHOP_HOST_CPU],[$host_cpu])
+AC_SUBST([HULAHOP_HOST_OS],[$host_os])
+
AM_INIT_AUTOMAKE([1.9 foreign dist-bzip2 no-dist-gzip])
AC_PROG_LIBTOOL
@@ -36,6 +46,10 @@ AC_SUBST([LIBXUL_LIBS])
AC_SUBST([LIBXUL_DIR])
AC_SUBST([LIBXUL_SDK_DIR])
+AC_CONFIG_FILES([
+components/xulappinfo.js
+])
+
AC_OUTPUT([
Makefile
components/Makefile