Web   ·   Wiki   ·   Activities   ·   Blog   ·   Lists   ·   Chat   ·   Meeting   ·   Bugs   ·   Git   ·   Translate   ·   Archive   ·   People   ·   Donate
summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorDan Winship <dwinship@redhat.com>2007-08-22 15:18:57 (GMT)
committer Dan Winship <dwinship@redhat.com>2007-08-22 15:18:57 (GMT)
commitf898ff656679d3c8b498ad3e316858da208d6a10 (patch)
tree05fc2e3cc60e0fa7467949bfaf4cce7c2819239d /configure.ac
parent49b43dff1a62ae728ffe834b6ee20f7c5be1e75c (diff)
Make this work on x86_64
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 1 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 11f8f04..fc19f65 100644
--- a/configure.ac
+++ b/configure.ac
@@ -27,8 +27,7 @@ PKG_CHECK_MODULES([LIBXUL],[libxul])
# to link to xpcom at build time. Which involves various hacks.
LIBXUL_PREFIX=`$PKG_CONFIG --variable=prefix libxul`
LIBXUL_SDK_DIR=`$PKG_CONFIG --variable=sdkdir libxul`
-LIBXUL_VERSION=`$PKG_CONFIG --modversion libxul`
-LIBXUL_DIR=$LIBXUL_PREFIX/lib/xulrunner-$LIBXUL_VERSION
+LIBXUL_DIR=`echo $LIBXUL_SDK_DIR | sed -e 's/-devel//'`
LIBXUL_LIBS="$LIBXUL_LIBS -L$LIBXUL_DIR -lpyxpcom"
LIBXUL_CFLAGS=`$PKG_CONFIG --cflags --define-variable=includetype=unstable libxul`