Web   ·   Wiki   ·   Activities   ·   Blog   ·   Lists   ·   Chat   ·   Meeting   ·   Bugs   ·   Git   ·   Translate   ·   Archive   ·   People   ·   Donate
summaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
authorJonas Smedegaard <dr@jones.dk>2008-05-26 11:22:43 (GMT)
committer Jonas Smedegaard <dr@jones.dk>2008-05-26 11:23:17 (GMT)
commit71d0a44d99aeb3eb7f85a3f5b2a40469d48a70bc (patch)
tree8bdd936284bc5bdb6f02ee3a6ed891b9eec8d5a6 /debian/rules
parent5c7b66ed214d9f90e7f1f865e51d892e14a36de1 (diff)
Switch to using newly released upstream tarball.
* Switch to using newly released upstream tarball. * Update copyright-check (only files dropped or replaced with auto-generated ones). * Compile with -fno-strict-aliasing to work around type punning * Update local cdbs snippets: + Drop patchsys-quilt.mk (only patch unneeded with tarball release). + Use upstream-tarball.mk to track upstream source releases. + Drop semi-auto-updating autotools. * Semi-auto-update debian/control to update build-dependencies: DEB_AUTO_UPDATE_DEBIAN_CONTROL=yes fakeroot debian/rules clean
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules54
1 files changed, 7 insertions, 47 deletions
diff --git a/debian/rules b/debian/rules
index 6886d34..a465958 100755
--- a/debian/rules
+++ b/debian/rules
@@ -3,66 +3,26 @@
# Copyright © 2008 Jonas Smedegaard <dr@jones.dk>
# NB! Local CDBS tweaks in use. More info in README.cdbs-tweaks
-
-# Regenerate automade files when explicitly requested with
-# DEB_BUILD_OPTIONS=init,git fakeroot debian/rules autogen
-ifneq (,$(findstring init,$(DEB_BUILD_OPTIONS)))
-DEB_AUTO_UPDATE_ACLOCAL = 1.10
-DEB_AUTO_UPDATE_AUTOMAKE = 1.10
-DEB_AUTO_UPDATE_AUTOCONF = 2.61
-DEB_AUTO_UPDATE_LIBTOOL = pre
-endif
-
-
DEB_BUILDDIR = build
DEB_PYTHON_SYSTEM = pycentral
+include debian/cdbs/1/rules/upstream-tarball.mk
include debian/cdbs/1/rules/copyright-check.mk
-include /usr/share/cdbs/1/rules/patchsys-quilt.mk
include debian/cdbs/1/class/python-autotools.mk
include /usr/share/cdbs/1/rules/debhelper.mk
include debian/cdbs/1/rules/buildinfo.mk
+DEB_UPSTREAM_PACKAGE = hulahop
+DEB_UPSTREAM_URL = http://dev.laptop.org/pub/sugar/sources/$(DEB_UPSTREAM_PACKAGE)
+DEB_UPSTREAM_TARBALL_EXTENSION = tar.bz2
+DEB_UPSTREAM_TARBALL_MD5 = 78c410628ae067ae01dbd1d6cecda618
+
pkg = python-hulahop
# Woraround for type punning causing "size of array 'arg' is negative"
CXXFLAGS += -fno-strict-aliasing
-DEB_MAKE_CHECK_TARGET = check
-
-# Regenerate automade files when explicitly requested with
-# DEB_BUILD_OPTIONS=init,git fakeroot debian/rules autogen
-# From a Git clone extend to DEB_BUILD_OPTIONS=init,git to save as a patch
-
-# Workaround: can't pass --install to autotools through CDBS
-# Also, CDBS only invokes aclocal if aclocal.m4 already exists
-autoreconf::
- autoreconf -i
-
-# Ensure possibly patch-created script is executable
-post-patches::
- chmod a+x py-compile
-
-ifneq (,$(findstring init,$(DEB_BUILD_OPTIONS)))
-DEB_PHONY_RULES += autogen
-autogen: autoreconf debian/stamp-autotools-files clean
-ifneq (,$(findstring git,$(DEB_BUILD_OPTIONS)))
-# find -name .gitignore -print0 | xargs -0 -r -I'{}' mv '{}' '{}'.cdbs_off
- git-ls-files -o -m -z -x debian/\* -x config.guess -x config.sub -x .gitignore -x .gitignore.cdbs_off \
- | xargs -0 -r git add -f --
- git diff --cached > debian/patches/2991_autoreconf.patch
- git reset
- git add debian/patches/2991_autoreconf.patch
-endif
-endif
-
-# Replace virtual automake1.10 build-dependency with automake
-CDBS_BUILD_DEPENDS := $(shell echo '$(CDBS_BUILD_DEPENDS)' | sed -e 's/\bautomake1\.10\b/automake/')
-
# Needed by upstream build process
CDBS_BUILD_DEPENDS := $(CDBS_BUILD_DEPENDS), xulrunner-dev (>= 1.9~b5-4~), python-xpcom (>= 1.9~b5-4~), python-gtk2-dev
# Merge duplicate build-dependencies
-CDBS_BUILD_DEPENDS := $(shell echo '$(CDBS_BUILD_DEPENDS)' | sed -e '/\bcdbs (>= 0.4.27-1)/ s/ *,* *\bcdbs (>= \(0.4.23-1.1\)) *,* */, /g' -e 's/^ *, *//' -e 's/ *, *$$//')
-
-# Avoid 1-revision in build-dependency
-CDBS_BUILD_DEPENDS := $(shell echo '$(CDBS_BUILD_DEPENDS)' | sed -e 's/\bcdbs (>= 0.4.27-1)/cdbs (>= 0.4.27)/')
+CDBS_BUILD_DEPENDS := $(shell echo '$(CDBS_BUILD_DEPENDS)' | sed -e '/\bcdbs (>= 0.4.39)/ s/ *,* *\bcdbs (>= \(0.4.23-1.1\|0.4.27-1\)) *,* */, /g' -e 's/^ *, *//' -e 's/ *, *$$//')