Web   ·   Wiki   ·   Activities   ·   Blog   ·   Lists   ·   Chat   ·   Meeting   ·   Bugs   ·   Git   ·   Translate   ·   Archive   ·   People   ·   Donate
summaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
authorJonas Smedegaard <dr@jones.dk>2008-08-16 10:39:21 (GMT)
committer Jonas Smedegaard <dr@jones.dk>2008-08-16 10:43:32 (GMT)
commitb236133f4a3a9cd613059f3516fe0ecb303cb9b8 (patch)
treef9e01d25ca9ecb801d1be85db6b9eaf704daca7d /debian/rules
parent81c0f35a037e2214ad368be47885461379e19a27 (diff)
Update cdbs snippets, copyright-hints and dependencies.
* Update cdbs snippets: + Move dependency cleanup to new local snippet package-relations.mk. + Update copyright-check output to more closely match proposed new copyright file format. Update copyright-hints. + Minor improvements to flavor-enhanced autotools- and makefile- snippets. + Update README.cdbs-tweaks. * Add DEB_MAINTAINER_MODE in debian/rules (thanks to Romain Beauxis). * Semi-auto-update debian/control to update dependencies: DEB_MAINTAINER_MODE=1 fakeroot debian/rules clean
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules16
1 files changed, 11 insertions, 5 deletions
diff --git a/debian/rules b/debian/rules
index 24ea583..1c5e5a0 100755
--- a/debian/rules
+++ b/debian/rules
@@ -5,6 +5,11 @@
# NB! Local CDBS tweaks in use. More info in README.cdbs-tweaks
DEB_BUILDDIR = build
DEB_PYTHON_SYSTEM = pycentral
+ifneq (,$(DEB_MAINTAINER_MODE))
+ # Enable stuff not policy compliant (eg. unsuitable for build daemons)
+ DEB_COPYRIGHT_CHECK_STRICT = yes
+ DEB_AUTO_UPDATE_DEBIAN_CONTROL = yes
+endif
include debian/cdbs/1/rules/upstream-tarball.mk
include debian/cdbs/1/rules/copyright-check.mk
include debian/cdbs/1/class/python-autotools.mk
@@ -31,11 +36,12 @@ clean::
# Minimum usable version of xulrunner
python-xpcom-minver = 1.9~rc2
-binary-predep/python-hulahop::
- echo "python-xpcom:Depends=python-xpcom (>= $(python-xpcom-minver))" >> debian/python-hulahop.substvars
+# Needed both by upstream build and at runtime
+CDBS_DEPENDS_$(pkg) := python-xpcom (>= $(python-xpcom-minver))
+CDBS_BUILD_DEPENDS := $(CDBS_BUILD_DEPENDS), $(CDBS_DEPENDS_$(pkg))
# Needed by upstream build process
-CDBS_BUILD_DEPENDS := $(CDBS_BUILD_DEPENDS), xulrunner-dev (>= $(python-xpcom-minver)), python-xpcom (>= $(python-xpcom-minver)), python-gtk2-dev
+CDBS_BUILD_DEPENDS := $(CDBS_BUILD_DEPENDS), xulrunner-dev (>= $(python-xpcom-minver)), python-gtk2-dev
-# Merge duplicate build-dependencies
-CDBS_BUILD_DEPENDS := $(shell echo '$(CDBS_BUILD_DEPENDS)' | sed -e '/\bcdbs (>= 0.4.39)/ s/ *,* *\bcdbs (>= \(0.4.23-1.1\|0.4.27\)) *,* */, /g' -e 's/^ *, *//' -e 's/ *, *$$//')
+# Resolve, cleanup and apply CDBS-declared dependencies
+include debian/cdbs/1/rules/package-relations.mk