Web   ·   Wiki   ·   Activities   ·   Blog   ·   Lists   ·   Chat   ·   Meeting   ·   Bugs   ·   Git   ·   Translate   ·   Archive   ·   People   ·   Donate
summaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
authorJonas Smedegaard <dr@jones.dk>2008-03-25 22:12:40 (GMT)
committer Jonas Smedegaard <dr@jones.dk>2008-04-29 14:18:14 (GMT)
commitbfe11be4cf7fba2e7ce2904eb35c824355a1138c (patch)
tree28b67efca7a883a09ee599db58e4be700e2e894d /debian/rules
parent5818437129222cb7a348f8a948e6b82a6bc5dc1d (diff)
Initial release. Closes: bug#444021.
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules65
1 files changed, 65 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..410d6ba
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,65 @@
+#!/usr/bin/make -f
+# -*- mode: makefile; coding: utf-8 -*-
+# Copyright © 2008 Jonas Smedegaard <dr@jones.dk>
+
+# NB! Local CDBS tweaks in use. More info in README.cdbs-tweaks
+
+# Regenerate automade files when explicitly requested with
+# DEB_BUILD_OPTIONS=init,git fakeroot debian/rules autogen
+ifneq (,$(findstring init,$(DEB_BUILD_OPTIONS)))
+DEB_AUTO_UPDATE_ACLOCAL = 1.10
+DEB_AUTO_UPDATE_AUTOMAKE = 1.10
+DEB_AUTO_UPDATE_AUTOCONF = 2.61
+DEB_AUTO_UPDATE_LIBTOOL = pre
+endif
+
+
+DEB_BUILDDIR = build
+DEB_PYTHON_SYSTEM = pycentral
+include debian/cdbs/1/rules/copyright-check.mk
+include /usr/share/cdbs/1/rules/patchsys-quilt.mk
+include debian/cdbs/1/class/python-autotools.mk
+include /usr/share/cdbs/1/rules/debhelper.mk
+include debian/cdbs/1/rules/buildinfo.mk
+
+pkg = python-hulahop
+
+DEB_MAKE_CHECK_TARGET = check
+
+# Regenerate automade files when explicitly requested with
+# DEB_BUILD_OPTIONS=init,git fakeroot debian/rules autogen
+# From a Git clone extend to DEB_BUILD_OPTIONS=init,git to save as a patch
+
+# Workaround: can't pass --install to autotools through CDBS
+# Also, CDBS only invokes aclocal if aclocal.m4 already exists
+autoreconf::
+ autoreconf -i
+
+# Ensure possibly patch-created script is executable
+post-patches::
+ chmod a+x py-compile
+
+ifneq (,$(findstring init,$(DEB_BUILD_OPTIONS)))
+DEB_PHONY_RULES += autogen
+autogen: autoreconf debian/stamp-autotools-files clean
+ifneq (,$(findstring git,$(DEB_BUILD_OPTIONS)))
+# find -name .gitignore -print0 | xargs -0 -r -I'{}' mv '{}' '{}'.cdbs_off
+ git-ls-files -o -m -z -x debian/\* -x config.guess -x config.sub -x .gitignore -x .gitignore.cdbs_off \
+ | xargs -0 -r git add -f --
+ git diff --cached > debian/patches/2991_autoreconf.patch
+ git reset
+ git add debian/patches/2991_autoreconf.patch
+endif
+endif
+
+# Replace virtual automake1.10 build-dependency with automake
+CDBS_BUILD_DEPENDS := $(shell echo '$(CDBS_BUILD_DEPENDS)' | sed -e 's/\bautomake1\.10\b/automake/')
+
+# Needed by upstream build process
+CDBS_BUILD_DEPENDS := $(CDBS_BUILD_DEPENDS), xulrunner-dev (>= 1.9~b5-3~), python-xpcom, python-gtk2-dev
+
+# Merge duplicate build-dependencies
+CDBS_BUILD_DEPENDS := $(shell echo '$(CDBS_BUILD_DEPENDS)' | sed -e '/\bcdbs (>= 0.4.27-1)/ s/ *,* *\bcdbs (>= \(0.4.23-1.1\)) *,* */, /g' -e 's/^ *, *//' -e 's/ *, *$$//')
+
+# Avoid 1-revision in build-dependency
+CDBS_BUILD_DEPENDS := $(shell echo '$(CDBS_BUILD_DEPENDS)' | sed -e 's/\bcdbs (>= 0.4.27-1)/cdbs (>= 0.4.27)/')