Web   ·   Wiki   ·   Activities   ·   Blog   ·   Lists   ·   Chat   ·   Meeting   ·   Bugs   ·   Git   ·   Translate   ·   Archive   ·   People   ·   Donate
summaryrefslogtreecommitdiffstats
path: root/debian
diff options
context:
space:
mode:
authorJonas Smedegaard <dr@jones.dk>2008-05-07 08:52:19 (GMT)
committer Jonas Smedegaard <dr@jones.dk>2008-05-07 09:01:04 (GMT)
commit0748e70bfa05e906d2dd77fe72b023d73d426e59 (patch)
tree28178b7e36cbb0d947a2b7044544a16bd5f6a961 /debian
parentdbcc9831f328fef64f9d0eaa4ce3a6f5b62dfd9b (diff)
Strip hardcoded rpath.debian/0.4.0.git.20071211-1
Diffstat (limited to 'debian')
-rw-r--r--debian/control2
-rwxr-xr-xdebian/rules7
2 files changed, 8 insertions, 1 deletions
diff --git a/debian/control b/debian/control
index f6f01e6..5376024 100644
--- a/debian/control
+++ b/debian/control
@@ -3,7 +3,7 @@ Section: python
Priority: optional
Maintainer: Debian OLPC <debian-olpc-devel@lists.alioth.debian.org>
Uploaders: Jonas Smedegaard <dr@jones.dk>
-Build-Depends: autotools-dev, devscripts (>= 2.10.7), quilt, patchutils (>= 0.2.25), cdbs (>= 0.4.27), python-all-dev (>= 2.3.5-11), python-central (>= 0.5.6), debhelper (>= 5), dh-buildinfo, xulrunner-dev (>= 1.9~b5-4~), python-xpcom (>= 1.9~b5-4~), python-gtk2-dev
+Build-Depends: autotools-dev, devscripts (>= 2.10.7), quilt, patchutils (>= 0.2.25), cdbs (>= 0.4.27), python-all-dev (>= 2.3.5-11), python-central (>= 0.5.6), debhelper (>= 5), dh-buildinfo, xulrunner-dev (>= 1.9~b5-4~), python-xpcom (>= 1.9~b5-4~), python-gtk2-dev, chrpath
Standards-Version: 3.7.3
Vcs-Git: git://git.debian.org/git/collab-maint/sugar-hulahop.git
Vcs-Browser: http://git.debian.org/?p=collab-maint/sugar-hulahop.git;a=summary
diff --git a/debian/rules b/debian/rules
index 7e0735e..b7ba291 100755
--- a/debian/rules
+++ b/debian/rules
@@ -39,6 +39,10 @@ autoreconf::
post-patches::
chmod a+x py-compile
+# Strip hardcoded rpath
+binary-strip/$(pkg)::
+ find $(DEB_DESTDIR)/usr/lib -type f -name '*.so' -exec chrpath -d '{}' ';'
+
ifneq (,$(findstring init,$(DEB_BUILD_OPTIONS)))
DEB_PHONY_RULES += autogen
autogen: autoreconf debian/stamp-autotools-files clean
@@ -58,6 +62,9 @@ CDBS_BUILD_DEPENDS := $(shell echo '$(CDBS_BUILD_DEPENDS)' | sed -e 's/\bautomak
# Needed by upstream build process
CDBS_BUILD_DEPENDS := $(CDBS_BUILD_DEPENDS), xulrunner-dev (>= 1.9~b5-4~), python-xpcom (>= 1.9~b5-4~), python-gtk2-dev
+# Needed for our packaging
+CDBS_BUILD_DEPENDS := $(CDBS_BUILD_DEPENDS), chrpath
+
# Merge duplicate build-dependencies
CDBS_BUILD_DEPENDS := $(shell echo '$(CDBS_BUILD_DEPENDS)' | sed -e '/\bcdbs (>= 0.4.27-1)/ s/ *,* *\bcdbs (>= \(0.4.23-1.1\)) *,* */, /g' -e 's/^ *, *//' -e 's/ *, *$$//')