Web   ·   Wiki   ·   Activities   ·   Blog   ·   Lists   ·   Chat   ·   Meeting   ·   Bugs   ·   Git   ·   Translate   ·   Archive   ·   People   ·   Donate
summaryrefslogtreecommitdiffstats
path: root/debian
diff options
context:
space:
mode:
authorJonas Smedegaard <dr@jones.dk>2008-05-26 11:50:17 (GMT)
committer Jonas Smedegaard <dr@jones.dk>2008-05-26 11:53:08 (GMT)
commita255363e668b601d326209fed644ca88cd9d2c18 (patch)
treed4da36baf27b4213a030bc703c58ea0492317846 /debian
parentba9faaaa7ac3081971c113d6869c28c92eba4974 (diff)
Tighten (build-)dependency on xulrunner, and rewrite to only declare version number once for both dependency and build-dependencies.
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog2
-rw-r--r--debian/control4
-rw-r--r--debian/control.in2
-rwxr-xr-xdebian/rules8
4 files changed, 12 insertions, 4 deletions
diff --git a/debian/changelog b/debian/changelog
index 6e5a8ac..4b15b4a 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -7,6 +7,8 @@ sugar-hulahop (0.4.0-1) experimental; urgency=low
causing "size of array 'arg' is negative".
* Bump debhelper compatibility level to 6 (was 5).
* Add watch file.
+ * Tighten (build-)dependency on xulrunner, and rewrite to only declare
+ version number once for both dependency and build-dependencies.
* Update local cdbs snippets:
+ Drop patchsys-quilt.mk (only patch unneeded with tarball release).
+ Use upstream-tarball.mk to track upstream source releases.
diff --git a/debian/control b/debian/control
index 04c53b5..9f9a4e0 100644
--- a/debian/control
+++ b/debian/control
@@ -3,7 +3,7 @@ Section: python
Priority: optional
Maintainer: Debian OLPC <debian-olpc-devel@lists.alioth.debian.org>
Uploaders: Jonas Smedegaard <dr@jones.dk>
-Build-Depends: cdbs (>= 0.4.39), autotools-dev, devscripts (>= 2.10.7), python-all-dev (>= 2.3.5-11), python-central (>= 0.5.6), debhelper (>= 5.0.44), dh-buildinfo, xulrunner-dev (>= 1.9~b5-4~), python-xpcom (>= 1.9~b5-4~), python-gtk2-dev
+Build-Depends: cdbs (>= 0.4.39), autotools-dev, devscripts (>= 2.10.7), python-all-dev (>= 2.3.5-11), python-central (>= 0.5.6), debhelper (>= 5.0.44), dh-buildinfo, xulrunner-dev (>= 1.9~rc1), python-xpcom (>= 1.9~rc1), python-gtk2-dev
Standards-Version: 3.7.3
Vcs-Git: git://git.debian.org/git/collab-maint/sugar-hulahop.git
Vcs-Browser: http://git.debian.org/?p=collab-maint/sugar-hulahop.git;a=summary
@@ -12,7 +12,7 @@ XS-Python-Version: all
Package: python-hulahop
Architecture: any
-Depends: ${shlibs:Depends}, ${python:Depends}, python-gtk2, python-gobject, python-xpcom (>= 1.9~b5-4~)
+Depends: ${shlibs:Depends}, ${python:Depends}, ${python-xpcom:Depends}, python-gtk2, python-gobject
Suggests: sugar-web-activity
Provides: ${python:Provides}
XB-Python-Version: ${python:Versions}
diff --git a/debian/control.in b/debian/control.in
index 3c11b20..c69790d 100644
--- a/debian/control.in
+++ b/debian/control.in
@@ -12,7 +12,7 @@ XS-Python-Version: all
Package: python-hulahop
Architecture: any
-Depends: ${shlibs:Depends}, ${python:Depends}, python-gtk2, python-gobject, python-xpcom (>= 1.9~b5-4~)
+Depends: ${shlibs:Depends}, ${python:Depends}, ${python-xpcom:Depends}, python-gtk2, python-gobject
Suggests: sugar-web-activity
Provides: ${python:Provides}
XB-Python-Version: ${python:Versions}
diff --git a/debian/rules b/debian/rules
index a465958..065ec41 100755
--- a/debian/rules
+++ b/debian/rules
@@ -21,8 +21,14 @@ pkg = python-hulahop
# Woraround for type punning causing "size of array 'arg' is negative"
CXXFLAGS += -fno-strict-aliasing
+# Minimum usable version of xulrunner
+python-xpcom-minver = 1.9~rc1
+
+binary-predep/python-hulahop::
+ echo "python-xpcom:Depends=python-xpcom (>= $(python-xpcom-minver))" >> debian/python-hulahop.substvars
+
# Needed by upstream build process
-CDBS_BUILD_DEPENDS := $(CDBS_BUILD_DEPENDS), xulrunner-dev (>= 1.9~b5-4~), python-xpcom (>= 1.9~b5-4~), python-gtk2-dev
+CDBS_BUILD_DEPENDS := $(CDBS_BUILD_DEPENDS), xulrunner-dev (>= $(python-xpcom-minver)), python-xpcom (>= $(python-xpcom-minver)), python-gtk2-dev
# Merge duplicate build-dependencies
CDBS_BUILD_DEPENDS := $(shell echo '$(CDBS_BUILD_DEPENDS)' | sed -e '/\bcdbs (>= 0.4.39)/ s/ *,* *\bcdbs (>= \(0.4.23-1.1\|0.4.27-1\)) *,* */, /g' -e 's/^ *, *//' -e 's/ *, *$$//')