Web   ·   Wiki   ·   Activities   ·   Blog   ·   Lists   ·   Chat   ·   Meeting   ·   Bugs   ·   Git   ·   Translate   ·   Archive   ·   People   ·   Donate
summaryrefslogtreecommitdiffstats
path: root/components/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'components/Makefile.am')
-rw-r--r--components/Makefile.am15
1 files changed, 15 insertions, 0 deletions
diff --git a/components/Makefile.am b/components/Makefile.am
new file mode 100644
index 0000000..23d2895
--- /dev/null
+++ b/components/Makefile.am
@@ -0,0 +1,15 @@
+xptdir = $(pkglibdir)/components
+xpt_in_files = hulahopAddCertException.idl
+xpt_DATA = $(xpt_in_files:.idl=.xpt)
+
+%.xpt: %.idl
+ $(LIBXUL_SDK_DIR)/bin/xpidl -m typelib -w -v -I $(LIBXUL_SDK_DIR)/idl -e $@ $<
+
+componentsdir = $(pkglibdir)/components
+components_DATA = hulahopAddCertException.js
+
+EXTRA_DIST = $(xpt_in_files)
+
+CLEANFILES = $(xpt_DATA)
+
+DISTCLEANFILES = $(xpt_DATA)