Web   ·   Wiki   ·   Activities   ·   Blog   ·   Lists   ·   Chat   ·   Meeting   ·   Bugs   ·   Git   ·   Translate   ·   Archive   ·   People   ·   Donate
summaryrefslogtreecommitdiffstats
path: root/data/chrome/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'data/chrome/Makefile.am')
-rw-r--r--data/chrome/Makefile.am24
1 files changed, 24 insertions, 0 deletions
diff --git a/data/chrome/Makefile.am b/data/chrome/Makefile.am
new file mode 100644
index 0000000..e38f1a2
--- /dev/null
+++ b/data/chrome/Makefile.am
@@ -0,0 +1,24 @@
+manifestdir = $(pkgdatadir)/chrome
+manifest_in_files = chrome.manifest.in
+manifest_DATA = $(manifest_in_files:.manifest.in=.manifest)
+
+%.manifest: %.manifest.in
+ @sed -e "s!@CHROMEDIR@!$(pkgdatadir)/chrome!g" $< > $@
+
+brandingdir = $(manifestdir)/branding
+branding_DATA = brand.properties
+
+globalchromedir = $(manifestdir)/global
+globalchrome_DATA = netError.dtd
+
+EXTRA_DIST = \
+ $(manifest_in_files) \
+ $(branding_in_files) \
+ $(globalchrome_DATA)
+
+CLEANFILES = \
+ $(manifest_DATA)
+
+DISTCLEANFILES = \
+ $(manifest_DATA) \
+ $(branding_DATA)