Web   ·   Wiki   ·   Activities   ·   Blog   ·   Lists   ·   Chat   ·   Meeting   ·   Bugs   ·   Git   ·   Translate   ·   Archive   ·   People   ·   Donate
summaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am36
1 files changed, 3 insertions, 33 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index efe531b..f023591 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -1,12 +1,6 @@
-sugardir = $(pythondir)/hulahop
-sugar_PYTHON = \
- __init__.py \
- webview.py
-
INCLUDES = \
$(DEPS_CFLAGS) \
$(PYTHON_INCLUDES) \
- $(PYGTK_CFLAGS) \
$(MOZILLA_CFLAGS) \
-I$(MOZILLA_INCLUDE_ROOT)/docshell \
-I$(MOZILLA_INCLUDE_ROOT)/dom \
@@ -19,34 +13,10 @@ INCLUDES = \
-I$(MOZILLA_INCLUDE_ROOT)/xpcom \
-DMOZILLA_HOME=\"$(MOZILLA_HOME)\"
-pkgpyexec_LTLIBRARIES = _hulahop.la
-
-_hulahop_la_LDFLAGS = -module -avoid-version -R$(MOZILLA_HOME) -dlopen self
-_hulahop_la_LIBADD = \
- $(GECKO_LIBS) \
- $(DEPS_LIBS) \
- $(MOZILLA_EXTRA_LIBS) \
- $(MOZILLA_GLUE_LIBS)
+noinst_LTLIBRARIES = libhulahop.la
-_hulahop_la_SOURCES = \
+libhulahop_la_SOURCES = \
HulahopDirectoryProvider.cpp \
HulahopDirectoryProvider.h \
hulahop-web-view.cpp \
- hulahop-web-view.h \
- hulahop.c \
- hulahopmodule.c
-
-hulahop.c: hulahop.defs hulahop.override
-
-CLEANFILES = hulahop.c
-EXTRA_DIST = hulahop.override hulahop.defs
-
-.defs.c:
- (cd $(srcdir)\
- && $(PYGTK_CODEGEN) \
- --register $(PYGTK_DEFSDIR)/gdk-types.defs \
- --register $(PYGTK_DEFSDIR)/gtk-types.defs \
- --override $*.override \
- --prefix py$* $*.defs) > gen-$*.c \
- && cp gen-$*.c $*.c \
- && rm -f gen-$*.c
+ hulahop-web-view.h