Web   ·   Wiki   ·   Activities   ·   Blog   ·   Lists   ·   Chat   ·   Meeting   ·   Bugs   ·   Git   ·   Translate   ·   Archive   ·   People   ·   Donate
summaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules16
1 files changed, 12 insertions, 4 deletions
diff --git a/debian/rules b/debian/rules
index 532b135..db0f515 100755
--- a/debian/rules
+++ b/debian/rules
@@ -4,13 +4,21 @@
# NB! Local CDBS tweaks in use. More info in README.cdbs-tweaks
DEB_PYTHON_SYSTEM = pycentral
+ifneq (,$(DEB_MAINTAINER_MODE))
+ # Enable stuff not policy compliant (eg. unsuitable for build daemons)
+ DEB_COPYRIGHT_CHECK_STRICT = yes
+ DEB_AUTO_UPDATE_DEBIAN_CONTROL = yes
+endif
+include debian/cdbs/1/rules/upstream-tarball.mk
include debian/cdbs/1/rules/copyright-check.mk
include /usr/share/cdbs/1/rules/patchsys-quilt.mk
include debian/cdbs/1/class/python-sugar.mk
include debian/cdbs/1/rules/buildinfo.mk
-# Merge duplicate build-dependencies
-CDBS_BUILD_DEPENDS := $(shell echo '$(CDBS_BUILD_DEPENDS)' | sed -e '/\bcdbs (>= 0.4.27-1)/ s/ *,* *\bcdbs (>= \(0.4.23-1.1\)) *,* */, /g' -e 's/^ *, *//' -e 's/ *, *$$//')
+DEB_UPSTREAM_PACKAGE = Memorize
+DEB_UPSTREAM_URL = http://dev.laptop.org/pub/sugar/sources/$(DEB_UPSTREAM_PACKAGE)
+DEB_UPSTREAM_TARBALL_EXTENSION = tar.bz2
+DEB_UPSTREAM_TARBALL_MD5 = 3a0103e515d1e75b493cea3229353193
-# Avoid 1-revision in build-dependency
-CDBS_BUILD_DEPENDS := $(shell echo '$(CDBS_BUILD_DEPENDS)' | sed -e 's/\bcdbs (>= 0.4.27-1)/cdbs (>= 0.4.27)/')
+# Resolve, cleanup and apply CDBS-declared dependencies
+include debian/cdbs/1/rules/package-relations.mk