Web   ·   Wiki   ·   Activities   ·   Blog   ·   Lists   ·   Chat   ·   Meeting   ·   Bugs   ·   Git   ·   Translate   ·   Archive   ·   People   ·   Donate
summaryrefslogtreecommitdiffstats
path: root/debian/cdbs/1/class
diff options
context:
space:
mode:
Diffstat (limited to 'debian/cdbs/1/class')
-rw-r--r--debian/cdbs/1/class/makefile.mk2
-rw-r--r--debian/cdbs/1/class/python-autotools.mk3
2 files changed, 3 insertions, 2 deletions
diff --git a/debian/cdbs/1/class/makefile.mk b/debian/cdbs/1/class/makefile.mk
index 2f4e98f..86b1175 100644
--- a/debian/cdbs/1/class/makefile.mk
+++ b/debian/cdbs/1/class/makefile.mk
@@ -46,7 +46,7 @@ DEB_PHONY_RULES += makefile-clean $(cdbs_make_clean_nonstamps)
pre-build::
$(if $(cdbs_make_multibuilds),mkdir -p debian/stamp-makefile-build debian/stamp-makefile-install)
- $(and $(cdbs_make_multibuilds),$(not $(findstring nocheck,$(DEB_BUILD_OPTIONS))),$(DEB_MAKE_CHECK_TARGET),mkdir -p debian/stamp-makefile-check)
+ $(and $(cdbs_make_multibuilds),$(DEB_MAKE_CHECK_TARGET),mkdir -p debian/stamp-makefile-check)
common-build-arch common-build-indep:: $(cdbs_make_build_stamps)
$(cdbs_make_build_stamps):
diff --git a/debian/cdbs/1/class/python-autotools.mk b/debian/cdbs/1/class/python-autotools.mk
index 28290d3..f75f67a 100644
--- a/debian/cdbs/1/class/python-autotools.mk
+++ b/debian/cdbs/1/class/python-autotools.mk
@@ -55,7 +55,8 @@ DEB_CONFIGURE_SCRIPT_ENV += PYTHON="python$(cdbs_make_curflavor)"
# This class can optionally use debhelper's commands.
# (if not, this build target should simply be ignored)
-$(patsubst %,binary-install/%,$(DEB_PACKAGES)) :: binary-install/%:
+$(patsubst %,binary-install/%,$(DEB_PACKAGES)) :: binary-install/%: binary-install-python/%
+$(patsubst %,binary-install-python/%,$(DEB_PACKAGES)) :: binary-install-python/%:
ifeq (pysupport, $(DEB_PYTHON_SYSTEM))
dh_pysupport -p$(cdbs_curpkg) $(DEB_PYTHON_PRIVATE_MODULES_DIRS) $(DEB_PYTHON_PRIVATE_MODULES_DIRS_$(cdbs_curpkg))
else