Web   ·   Wiki   ·   Activities   ·   Blog   ·   Lists   ·   Chat   ·   Meeting   ·   Bugs   ·   Git   ·   Translate   ·   Archive   ·   People   ·   Donate
summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorDaniel Narvaez <dwnarvaez@gmail.com>2012-12-07 09:47:26 (GMT)
committer Simon Schampijer <simon@laptop.org>2013-01-22 09:01:05 (GMT)
commita1af468373c982cb9a87ea6564c293b71306664b (patch)
tree378b09f5cfbeaa549b5c36ce4b370d2a484c0a7a /Makefile.am
parenta7452747ff3046444bda8730b2226166df8b4b5c (diff)
Add a test for the activities list palette
It doesn't really test the resulting UI yet but even just constructing the widget can catch some bugs. Acked-by: Simon Schampijer <simon@laptop.org>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am8
1 files changed, 8 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 9e252af..d024f44 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,3 +1,5 @@
+TESTS_TMPDIR=$(abs_builddir)/tests-tmp
+
SUBDIRS = bin data po src extensions
DISTCLEANFILES = \
@@ -12,3 +14,9 @@ EXTRA_DIST = \
intltool-extract.in
DISTCHECK_CONFIGURE_FLAGS = --disable-update-mimedb
+
+test:
+ cd $(top_srcdir)/tests && \
+ mkdir -p $(TESTS_TMPDIR) && \
+ TMPDIR=$(TESTS_TMPDIR) python -m unittest discover && \
+ rm -rf $(TESTS_TMPDIR)