Web   ·   Wiki   ·   Activities   ·   Blog   ·   Lists   ·   Chat   ·   Meeting   ·   Bugs   ·   Git   ·   Translate   ·   Archive   ·   People   ·   Donate
summaryrefslogtreecommitdiffstats
path: root/gtk3/engine/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'gtk3/engine/Makefile.am')
-rw-r--r--gtk3/engine/Makefile.am17
1 files changed, 17 insertions, 0 deletions
diff --git a/gtk3/engine/Makefile.am b/gtk3/engine/Makefile.am
new file mode 100644
index 0000000..c4b5c57
--- /dev/null
+++ b/gtk3/engine/Makefile.am
@@ -0,0 +1,17 @@
+enginedir = $(libdir)/gtk-3.0/$(GTK_VERSION)/theming-engines
+engine_LTLIBRARIES = libsugar.la
+
+INCLUDES = \
+ $(ENGINE3_CFLAGS)
+
+libsugar_la_SOURCES = \
+ sugar_utils.h \
+ sugar_utils.c \
+ sugar_engine.c
+
+libsugar_la_LDFLAGS = -module -avoid-version -no-undefined -export-symbols $(top_srcdir)/gtk3/engine/engine.symbols
+libsugar_la_LIBADD = $(ENGINE3_LIBS)
+
+EXTRA_DIST = engine.symbols
+
+-include $(top_srcdir)/git.mk