Web   ·   Wiki   ·   Activities   ·   Blog   ·   Lists   ·   Chat   ·   Meeting   ·   Bugs   ·   Git   ·   Translate   ·   Archive   ·   People   ·   Donate
summaryrefslogtreecommitdiffstats
path: root/data/levels/level_format.spec
diff options
context:
space:
mode:
Diffstat (limited to 'data/levels/level_format.spec')
-rw-r--r--data/levels/level_format.spec41
1 files changed, 5 insertions, 36 deletions
diff --git a/data/levels/level_format.spec b/data/levels/level_format.spec
index 587efee..e8bc1a5 100644
--- a/data/levels/level_format.spec
+++ b/data/levels/level_format.spec
@@ -1,5 +1,6 @@
Level object:
-{
+
+LEVEL = {
"id" : "",
"placed" : [
{
@@ -18,40 +19,8 @@ Level object:
"goals" : [
["projectile object name", "target object name"]
],
- "help" : "filename"
+ "helpImage": "filename",
+ "helpTitle": "descriptive title",
+ "helpMes" : "The help message"
}
-An example:
-{
- "id" : "first level",
- "placed" : [
- {
- "type" : "SoccerBall",
- "name" : "bola",
- "xpos" : "200",
- "ypos" : "300"
- },
- {
- "type" : "Esteira",
- "name" : "rolante",
- "xpos" : "300",
- "ypos" : "500"
- },
- {
- "type" : "Target",
- "name" : "alvo",
- "xpos" : "1000",
- "ypos" : "600"
- }
- ],
- "available": [
- {
- "type" : "Penguin",
- "name" : "tux"
- }
- ],
- "goals" : [
- ["bola", "alvo"]
- ],
- "help" : "help1.png"
-}