Web   ·   Wiki   ·   Activities   ·   Blog   ·   Lists   ·   Chat   ·   Meeting   ·   Bugs   ·   Git   ·   Translate   ·   Archive   ·   People   ·   Donate
summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMarco Pesenti Gritti <mpg@redhat.com>2007-01-23 21:13:03 (GMT)
committer Marco Pesenti Gritti <mpg@redhat.com>2007-01-23 21:13:03 (GMT)
commite392cbc6504337a293ba7abf5489548064e08bab (patch)
tree3cefa9751f4336f08a57246e7b622368a7e095ce /configure.ac
parent1d6f0a11c4d2f176f81bb6cefc2090893c7ed0b8 (diff)
Some cleanups
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 4 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 79022f4..4dab771 100644
--- a/configure.ac
+++ b/configure.ac
@@ -25,10 +25,12 @@ AC_PATH_PROG(PYGTK_CODEGEN, pygtk-codegen-2.0, no)
PKG_CHECK_MODULES(PYGTK, pygtk-2.0)
-PKG_CHECK_MODULES(GTKMOZEMBED, [xulrunner-gtkmozembed >= 1.8],
+PKG_CHECK_MODULES(LIB, gtk+-2.0 gstreamer-0.10 gstreamer-plugins-base-0.10)
+
+PKG_CHECK_MODULES(GECKO, [xulrunner-gtkmozembed >= 1.8],
[have_gecko=true; mozpackage=xulrunner],
[
-PKG_CHECK_MODULES(GTKMOZEMBED, [firefox-gtkmozembed >= 1.5],
+PKG_CHECK_MODULES(GECKO, [firefox-gtkmozembed >= 1.5],
[have_gecko=true; mozpackage=firefox],
have_gecko=false)
])
@@ -37,8 +39,6 @@ if test "x$have_gecko" = xfalse; then
AC_MSG_ERROR([Could not find xulrunner, mozilla or firefox $mozilla_required_version])
fi
-PKG_CHECK_MODULES(LIB, gtk+-2.0 $mozpackage-gtkmozembed gstreamer-0.10 gstreamer-plugins-base-0.10)
-
MOZILLA_HOME="`$PKG_CONFIG --variable=libdir $mozpackage-gtkmozembed`"
AC_SUBST(MOZILLA_HOME)