Web   ·   Wiki   ·   Activities   ·   Blog   ·   Lists   ·   Chat   ·   Meeting   ·   Bugs   ·   Git   ·   Translate   ·   Archive   ·   People   ·   Donate
summaryrefslogtreecommitdiffstats
path: root/lib/Makefile.am
diff options
context:
space:
mode:
authorMarco Pesenti Gritti <marco@localhost.localdomain>2007-06-20 13:22:12 (GMT)
committer Marco Pesenti Gritti <marco@localhost.localdomain>2007-06-20 13:22:12 (GMT)
commitc91bbd18ccf00b87d0e99029235f120b1b7839d6 (patch)
tree2eca21668e716d903999fade320e04258fe0edcf /lib/Makefile.am
parent61314c97057b34292cf30b771d98274b8f29bd85 (diff)
Move SugarKeyGrabber in the lib. Keep it private.
We can't install libraries in datadir.
Diffstat (limited to 'lib/Makefile.am')
-rw-r--r--lib/Makefile.am33
1 files changed, 33 insertions, 0 deletions
diff --git a/lib/Makefile.am b/lib/Makefile.am
index cd0d457..2ade166 100644
--- a/lib/Makefile.am
+++ b/lib/Makefile.am
@@ -10,7 +10,40 @@ libsugar_la_LIBADD = \
$(top_builddir)/lib/xdgmime/libxdgmime.la
libsugar_la_SOURCES = \
+ $(BUILT_SOURCES) \
+ eggaccelerators.c \
+ eggaccelerators.h \
sugar-address-entry.c \
sugar-address-entry.h \
+ sugar-key-grabber.c \
+ sugar-key-grabber.h \
sugar-x11-util.c \
sugar-x11-util.h
+
+BUILT_SOURCES = \
+ sugar-marshal.c \
+ sugar-marshal.h
+
+stamp_files = \
+ stamp-sugar-marshal.c \
+ stamp-sugar-marshal.h
+
+sugar-marshal.c: stamp-sugar-marshal.c
+ @true
+stamp-sugar-marshal.c: sugar-marshal.list
+ $(GLIB_GENMARSHAL) --prefix=sugar_marshal \
+ $(srcdir)/sugar-marshal.list --header --body > \
+ sugar-marshal.c && echo timestamp > $(@F)
+
+sugar-marshal.h: stamp-sugar-marshal.h
+ @true
+stamp-sugar-marshal.h: sugar-marshal.list
+ $(GLIB_GENMARSHAL) --prefix=sugar_marshal \
+ $(srcdir)/sugar-marshal.list --header > \
+ sugar-marshal.h && echo timestamp > $(@F)
+
+CLEANFILES = $(stamp_files) $(BUILT_SOURCES)
+DISTCLEANFILES = $(stamp_files) $(BUILT_SOURCES)
+MAINTAINERCLEANFILES = $(stamp_files) $(BUILT_SOURCES)
+
+EXTRA_DIST = sugar-marshal.list