Web   ·   Wiki   ·   Activities   ·   Blog   ·   Lists   ·   Chat   ·   Meeting   ·   Bugs   ·   Git   ·   Translate   ·   Archive   ·   People   ·   Donate
summaryrefslogtreecommitdiffstats
path: root/services/shell/Makefile.am
diff options
context:
space:
mode:
authorMarco Pesenti Gritti <mpg@redhat.com>2007-10-16 15:18:43 (GMT)
committer Marco Pesenti Gritti <mpg@redhat.com>2007-10-16 15:18:43 (GMT)
commit40fc6e2e47b956eabc34d8b772c066d8f8f0d530 (patch)
tree5dd559f6b9dbd16ddbbd3e0bbcfe1e8b05853020 /services/shell/Makefile.am
parent05236c66702b4d674123a50061c553ae9e11d589 (diff)
Simplify the API to get icon/description for objects.
Get rid of the service for now, it's not necessary until we allow activities to extend the mime type -> generic type mapping (post 1.0)
Diffstat (limited to 'services/shell/Makefile.am')
-rw-r--r--services/shell/Makefile.am9
1 files changed, 3 insertions, 6 deletions
diff --git a/services/shell/Makefile.am b/services/shell/Makefile.am
index b34b974..44496ff 100644
--- a/services/shell/Makefile.am
+++ b/services/shell/Makefile.am
@@ -2,13 +2,11 @@ servicedir = $(datadir)/dbus-1/services
service_in_files = \
org.laptop.ActivityRegistry.service.in \
- org.laptop.Clipboard.service.in \
- org.laptop.ObjectTypeRegistry.service.in
+ org.laptop.Clipboard.service.in
service_DATA = \
org.laptop.ActivityRegistry.service \
- org.laptop.Clipboard.service \
- org.laptop.ObjectTypeRegistry.service
+ org.laptop.Clipboard.service
org.laptop.ActivityRegistry.service: org.laptop.ActivityRegistry.service.in Makefile
@sed -e "s|\@bindir\@|$(bindir)|" $< > $@
@@ -26,8 +24,7 @@ sugar_PYTHON = \
activityregistryservice.py \
bundleregistry.py \
clipboardobject.py \
- clipboardservice.py \
- objecttypeservice.py
+ clipboardservice.py
bin_SCRIPTS = sugar-shell-service