Web   ·   Wiki   ·   Activities   ·   Blog   ·   Lists   ·   Chat   ·   Meeting   ·   Bugs   ·   Git   ·   Translate   ·   Archive   ·   People   ·   Donate
summaryrefslogtreecommitdiffstats
path: root/bindings/gecko/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'bindings/gecko/Makefile.am')
-rw-r--r--bindings/gecko/Makefile.am33
1 files changed, 0 insertions, 33 deletions
diff --git a/bindings/gecko/Makefile.am b/bindings/gecko/Makefile.am
deleted file mode 100644
index 7da2e52..0000000
--- a/bindings/gecko/Makefile.am
+++ /dev/null
@@ -1,33 +0,0 @@
-INCLUDES = \
- $(PYTHON_INCLUDES) \
- $(PYGTK_CFLAGS) \
- $(GECKO_CFLAGS)
-
-geckodir = $(pkgdatadir)/bindings
-pkgpyexecdir = $(geckodir)
-
-pkgpyexec_LTLIBRARIES = gecko.la
-
-gecko_la_LDFLAGS = -module -avoid-version
-gecko_la_LIBADD = $(GECKO_LIBS)
-
-gecko_la_SOURCES = \
- geckomodule.c \
- gecko-browser.h \
- gecko-browser.cpp
-
-nodist_gecko_la_SOURCES = gecko.c
-
-gecko.c: gecko.defs gecko.override
-
-CLEANFILES = gecko.c
-EXTRA_DIST = gecko.override gecko.defs
-
-.defs.c:
- (cd $(srcdir)\
- && $(PYGTK_CODEGEN) \
- --register $(GNOMEPYTHONEXTRAS_DEFSDIR)/gtkmozembed.defs \
- --override $*.override \
- --prefix py$* $*.defs) > gen-$*.c \
- && cp gen-$*.c $*.c \
- && rm -f gen-$*.c