Web   ·   Wiki   ·   Activities   ·   Blog   ·   Lists   ·   Chat   ·   Meeting   ·   Bugs   ·   Git   ·   Translate   ·   Archive   ·   People   ·   Donate
summaryrefslogtreecommitdiffstats
path: root/lib/ui/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'lib/ui/Makefile.am')
-rw-r--r--lib/ui/Makefile.am48
1 files changed, 48 insertions, 0 deletions
diff --git a/lib/ui/Makefile.am b/lib/ui/Makefile.am
new file mode 100644
index 0000000..3640a08
--- /dev/null
+++ b/lib/ui/Makefile.am
@@ -0,0 +1,48 @@
+libsugarui_la_CPPFLAGS = \
+ $(LIB_CFLAGS)
+
+noinst_LTLIBRARIES = libsugarui.la
+
+libsugarui_la_LIBADD = \
+ $(LIB_LIBS)
+
+libsugarui_la_SOURCES = \
+ $(BUILT_SOURCES) \
+ eggaccelerators.c \
+ eggaccelerators.h \
+ sugar-address-entry.c \
+ sugar-address-entry.h \
+ sugar-key-grabber.c \
+ sugar-key-grabber.h \
+ sugar-menu.h \
+ sugar-menu.c \
+ sugar-x11-util.c \
+ sugar-x11-util.h
+
+BUILT_SOURCES = \
+ sugar-marshal.c \
+ sugar-marshal.h
+
+stamp_files = \
+ stamp-sugar-marshal.c \
+ stamp-sugar-marshal.h
+
+sugar-marshal.c: stamp-sugar-marshal.c
+ @true
+stamp-sugar-marshal.c: sugar-marshal.list
+ $(GLIB_GENMARSHAL) --prefix=sugar_marshal \
+ $(srcdir)/sugar-marshal.list --header --body > \
+ sugar-marshal.c && echo timestamp > $(@F)
+
+sugar-marshal.h: stamp-sugar-marshal.h
+ @true
+stamp-sugar-marshal.h: sugar-marshal.list
+ $(GLIB_GENMARSHAL) --prefix=sugar_marshal \
+ $(srcdir)/sugar-marshal.list --header > \
+ sugar-marshal.h && echo timestamp > $(@F)
+
+CLEANFILES = $(stamp_files) $(BUILT_SOURCES)
+DISTCLEANFILES = $(stamp_files) $(BUILT_SOURCES)
+MAINTAINERCLEANFILES = $(stamp_files) $(BUILT_SOURCES)
+
+EXTRA_DIST = sugar-marshal.list