Web   ·   Wiki   ·   Activities   ·   Blog   ·   Lists   ·   Chat   ·   Meeting   ·   Bugs   ·   Git   ·   Translate   ·   Archive   ·   People   ·   Donate
summaryrefslogtreecommitdiffstats
path: root/sugar/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'sugar/Makefile.am')
-rw-r--r--sugar/Makefile.am36
1 files changed, 36 insertions, 0 deletions
diff --git a/sugar/Makefile.am b/sugar/Makefile.am
index 937441c..93e548d 100644
--- a/sugar/Makefile.am
+++ b/sugar/Makefile.am
@@ -9,3 +9,39 @@ sugar_PYTHON = \
ltihooks.py \
profile.py \
util.py
+
+INCLUDES = \
+ $(LIB_CFLAGS) \
+ $(LIB_BINDINGS_CFLAGS) \
+ $(PYTHON_INCLUDES) \
+ -I$(top_srcdir)/lib
+
+pkgpyexecdir = $(pythondir)/sugar
+
+pkgpyexec_LTLIBRARIES = _sugarext.la
+
+_sugarext_la_LDFLAGS = -module -avoid-version
+_sugarext_la_LIBADD = \
+ $(LIB_BINDINGS_LIBS) \
+ $(LIB_LIBS) \
+ $(top_builddir)/lib/libsugar.la
+
+_sugarext_la_SOURCES = \
+ _sugarextmodule.c
+
+nodist__sugarext_la_SOURCES = _sugarext.c
+
+_sugarext.c: _sugarext.defs _sugarext.override
+
+CLEANFILES = _sugarext.c
+EXTRA_DIST = _sugarext.override _sugarext.defs
+
+.defs.c:
+ (cd $(srcdir)\
+ && $(PYGTK_CODEGEN) \
+ --register $(PYGTK_DEFSDIR)/gdk-types.defs \
+ --register $(PYGTK_DEFSDIR)/gtk-types.defs \
+ --override $*.override \
+ --prefix py$* $*.defs) > gen-$*.c \
+ && cp gen-$*.c $*.c \
+ && rm -f gen-$*.c