Web   ·   Wiki   ·   Activities   ·   Blog   ·   Lists   ·   Chat   ·   Meeting   ·   Bugs   ·   Git   ·   Translate   ·   Archive   ·   People   ·   Donate
summaryrefslogtreecommitdiffstats
path: root/lib/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'lib/src/Makefile.am')
-rw-r--r--lib/src/Makefile.am29
1 files changed, 28 insertions, 1 deletions
diff --git a/lib/src/Makefile.am b/lib/src/Makefile.am
index ec762da..66897a3 100644
--- a/lib/src/Makefile.am
+++ b/lib/src/Makefile.am
@@ -7,6 +7,7 @@ noinst_LTLIBRARIES = libsugarprivate.la
libsugarprivate_la_LIBADD = $(GECKO_LIBS)
libsugarprivate_la_SOURCES = \
+ $(BUILT_SOURCES) \
eggaccelerators.h \
eggaccelerators.c \
sugar-browser.h \
@@ -14,4 +15,30 @@ libsugarprivate_la_SOURCES = \
sugar-address-entry.h \
sugar-address-entry.c \
sugar-key-grabber.h \
- sugar-key-grabber.c
+ sugar-key-grabber.c \
+ sugar-tray-manager.c \
+ sugar-tray-manager.h
+
+BUILT_SOURCES = \
+ sugar-marshal.c \
+ sugar-marshal.h
+
+stamp_files = \
+ stamp-sugar-marshal.c \
+ stamp-sugar-marshal.h
+
+sugar-marshal.c: stamp-sugar-marshal.c
+ @true
+stamp-sugar-marshal.c: sugar-marshal.list
+ $(GLIB_GENMARSHAL) --prefix=sugar_marshal $(srcdir)/sugar-marshal.list --header --body > sugar-marshal.c \
+ && echo timestamp > $(@F)
+
+sugar-marshal.h: stamp-sugar-marshal.h
+ @true
+stamp-sugar-marshal.h: sugar-marshal.list
+ $(GLIB_GENMARSHAL) --prefix=sugar_marshal $(srcdir)/sugar-marshal.list --header > sugar-marshal.h \
+ && echo timestamp > $(@F)
+
+CLEANFILES = $(stamp_files)
+DISTCLEANFILES = $(stamp_files)
+MAINTAINERCLEANFILES = $(stamp_files)