Web   ·   Wiki   ·   Activities   ·   Blog   ·   Lists   ·   Chat   ·   Meeting   ·   Bugs   ·   Git   ·   Translate   ·   Archive   ·   People   ·   Donate
summaryrefslogtreecommitdiffstats
path: root/threadframe/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'threadframe/Makefile.am')
-rw-r--r--threadframe/Makefile.am13
1 files changed, 13 insertions, 0 deletions
diff --git a/threadframe/Makefile.am b/threadframe/Makefile.am
new file mode 100644
index 0000000..e2cbd43
--- /dev/null
+++ b/threadframe/Makefile.am
@@ -0,0 +1,13 @@
+all:
+ python setup.py build
+
+install:
+ python setup.py install --prefix=${prefix}
+
+uninstall:
+ rm -f ${prefix}/lib/python2.4/site-packages/threadframe.so
+
+clean:
+ python setup.py clean
+ -rm -rf build
+ -rm -f core *~ *.so *.o *.pyd *.a python*.def