Web   ·   Wiki   ·   Activities   ·   Blog   ·   Lists   ·   Chat   ·   Meeting   ·   Bugs   ·   Git   ·   Translate   ·   Archive   ·   People   ·   Donate
summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Narvaez <dwnarvaez@gmail.com>2012-12-28 20:48:23 (GMT)
committer Daniel Narvaez <dwnarvaez@gmail.com>2012-12-28 20:48:23 (GMT)
commita76f5c9526141437d882d001b2b45e3a38920442 (patch)
tree6c84d253263f4050e16bc87899e0f61de397b6d0
parentef443c2bd7e8e5581d6634a6a14b803b21e520ae (diff)
Step into the tests directory
Not really sure why but otherwise plugins imports fails.
-rw-r--r--Makefile.commands4
-rwxr-xr-xcommands/check4
2 files changed, 4 insertions, 4 deletions
diff --git a/Makefile.commands b/Makefile.commands
index 70ec612..96f0af1 100644
--- a/Makefile.commands
+++ b/Makefile.commands
@@ -36,5 +36,5 @@ build-%:
pull-%:
@$(COMMANDS_DIR)/pull $*
-run-tests-%:
- @$(COMMANDS_DIR)/run-tests $*
+check-%:
+ @$(COMMANDS_DIR)/check $*
diff --git a/commands/check b/commands/check
index 21b5d75..ff4ac32 100755
--- a/commands/check
+++ b/commands/check
@@ -64,9 +64,9 @@ def _check_devbot():
os.environ["TESTS_TMP"] = tests_tmp
os.environ["PYTHONPATH"] = common.base_dir
+ os.chdir(os.path.join(common.base_dir, "tests", "devbot"))
- command.run(["python", "-m", "unittest", "discover",
- os.path.join(common.base_dir, "tests", "devbot")])
+ command.run(["python", "-m", "unittest", "discover"])
shutil.rmtree(tests_tmp, ignore_errors=True)