Web   ·   Wiki   ·   Activities   ·   Blog   ·   Lists   ·   Chat   ·   Meeting   ·   Bugs   ·   Git   ·   Translate   ·   Archive   ·   People   ·   Donate
summaryrefslogtreecommitdiffstats
path: root/Makefile.tests
diff options
context:
space:
mode:
authorDaniel Narvaez <dwnarvaez@gmail.com>2012-12-28 17:06:43 (GMT)
committer Daniel Narvaez <dwnarvaez@gmail.com>2012-12-28 17:06:43 (GMT)
commit4220aeb1963979971d498203b2d33d37c3b3d210 (patch)
tree63dcea0c1e416bd483f7627691ca4d743ba596ef /Makefile.tests
parent02c54b8d30a5010f074cba3a51ee814f739730ea (diff)
Rename tests to check
Diffstat (limited to 'Makefile.tests')
-rw-r--r--Makefile.tests29
1 files changed, 0 insertions, 29 deletions
diff --git a/Makefile.tests b/Makefile.tests
deleted file mode 100644
index 2d6e7bc..0000000
--- a/Makefile.tests
+++ /dev/null
@@ -1,29 +0,0 @@
-TESTS_TMP=$(TESTS_DIR)/tmp
-
-test-devbot:
- mkdir -p $(TESTS_TMP) && \
- cd tests/devbot && \
- TMPDIR=$(TESTS_TMP) PYTHONPATH=$(BASE_DIR) python -m unittest discover
- rm -rf $(TESTS_TMP)
-
-PYTHON_SCRIPTS = \
- $(COMMANDS_DIR)/build \
- $(COMMANDS_DIR)/clean \
- $(COMMANDS_DIR)/pull \
- $(COMMANDS_DIR)/run-tests \
- $(COMMANDS_DIR)/shell \
- $(COMMANDS_DIR)/check-system \
- $(COMMANDS_DIR)/distribute \
- $(COMMANDS_DIR)/run \
- $(COMMANDS_DIR)/send-patches \
- $(TOOLS_DIR)/json-normalize
-
-pylint:
- PYTHONPATH=$(COMMANDS_DIR) \
- pylint --reports=n --disable=C,W,R,E,F --enable=W0611 \
- devbot $(PYTHON_SCRIPTS)
-
-pep8:
- pep8 commands devbot tests $(PYTHON_SCRIPTS)
-
-check: test-devbot pep8 pylint run-tests