Web   ·   Wiki   ·   Activities   ·   Blog   ·   Lists   ·   Chat   ·   Meeting   ·   Bugs   ·   Git   ·   Translate   ·   Archive   ·   People   ·   Donate
summaryrefslogtreecommitdiffstats
path: root/devbot/build.py
diff options
context:
space:
mode:
authorDaniel Narvaez <dwnarvaez@gmail.com>2012-11-24 16:40:08 (GMT)
committer Daniel Narvaez <dwnarvaez@gmail.com>2012-11-24 16:40:08 (GMT)
commit1a4c87bafe4bd1e62bfc0353f0be3486efd837c1 (patch)
treefc3dd2ffbbae4e11aa8b990d0c08a76abc350cc7 /devbot/build.py
parente8b3bdcb34e62c2cd371fe67562e753d4d4a6a16 (diff)
Properly distinguish between prefix and install dir
Diffstat (limited to 'devbot/build.py')
-rw-r--r--devbot/build.py5
1 files changed, 3 insertions, 2 deletions
diff --git a/devbot/build.py b/devbot/build.py
index d6f42fb..ca0bc07 100644
--- a/devbot/build.py
+++ b/devbot/build.py
@@ -83,7 +83,7 @@ def build_autotools(module):
jobs = multiprocessing.cpu_count() * 2
args = [autogen,
- "--prefix", config.install_dir,
+ "--prefix", config.prefix_dir,
"--libdir", config.lib_dir]
args.extend(module.options)
@@ -95,7 +95,7 @@ def build_autotools(module):
unlink_libtool_files()
def build_activity(module):
- command.run(["./setup.py", "install", "--prefix", config.install_dir])
+ command.run(["./setup.py", "install", "--prefix", config.prefix_dir])
def build_module(module):
module_source_dir = module.get_source_dir()
@@ -159,6 +159,7 @@ def build():
def clean():
rmtree(config.install_dir)
+ rmtree(config.prefix_dir)
rmtree(config.build_dir)
for module in config.load_modules():