Web   ·   Wiki   ·   Activities   ·   Blog   ·   Lists   ·   Chat   ·   Meeting   ·   Bugs   ·   Git   ·   Translate   ·   Archive   ·   People   ·   Donate
summaryrefslogtreecommitdiffstats
path: root/Makefile.check
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.check')
-rw-r--r--Makefile.check29
1 files changed, 0 insertions, 29 deletions
diff --git a/Makefile.check b/Makefile.check
deleted file mode 100644
index 2d6e7bc..0000000
--- a/Makefile.check
+++ /dev/null
@@ -1,29 +0,0 @@
-TESTS_TMP=$(TESTS_DIR)/tmp
-
-test-devbot:
- mkdir -p $(TESTS_TMP) && \
- cd tests/devbot && \
- TMPDIR=$(TESTS_TMP) PYTHONPATH=$(BASE_DIR) python -m unittest discover
- rm -rf $(TESTS_TMP)
-
-PYTHON_SCRIPTS = \
- $(COMMANDS_DIR)/build \
- $(COMMANDS_DIR)/clean \
- $(COMMANDS_DIR)/pull \
- $(COMMANDS_DIR)/run-tests \
- $(COMMANDS_DIR)/shell \
- $(COMMANDS_DIR)/check-system \
- $(COMMANDS_DIR)/distribute \
- $(COMMANDS_DIR)/run \
- $(COMMANDS_DIR)/send-patches \
- $(TOOLS_DIR)/json-normalize
-
-pylint:
- PYTHONPATH=$(COMMANDS_DIR) \
- pylint --reports=n --disable=C,W,R,E,F --enable=W0611 \
- devbot $(PYTHON_SCRIPTS)
-
-pep8:
- pep8 commands devbot tests $(PYTHON_SCRIPTS)
-
-check: test-devbot pep8 pylint run-tests