Web   ·   Wiki   ·   Activities   ·   Blog   ·   Lists   ·   Chat   ·   Meeting   ·   Bugs   ·   Git   ·   Translate   ·   Archive   ·   People   ·   Donate
summaryrefslogtreecommitdiffstats
path: root/Makefile.helpers
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.helpers')
-rw-r--r--Makefile.helpers17
1 files changed, 17 insertions, 0 deletions
diff --git a/Makefile.helpers b/Makefile.helpers
new file mode 100644
index 0000000..7bd2ad4
--- /dev/null
+++ b/Makefile.helpers
@@ -0,0 +1,17 @@
+HELPERS = $(COMMANDS)/helpers
+
+XRANDR_LIBS = $(shell pkg-config --libs xrandr x11)
+X11_LIBS = $(shell pkg-config --libs x11)
+
+$(HELPERS)/list-outputs: $(HELPERS)/list-outputs.c
+ gcc -o $(HELPERS)/list-outputs \
+ $(HELPERS)/list-outputs.c $(XRANDR_LIBS)
+
+$(HELPERS)/find-free-display: $(HELPERS)/find-free-display.c
+ gcc -o $(HELPERS)/find-free-display \
+ $(HELPERS)/find-free-display.c $(X11_LIBS)
+
+helpers: $(HELPERS)/list-outputs $(HELPERS)/find-free-display
+
+clean-helpers:
+ rm -f $(HELPERS)/list-outputs $(HELPERS)/find-free-display