Web   ·   Wiki   ·   Activities   ·   Blog   ·   Lists   ·   Chat   ·   Meeting   ·   Bugs   ·   Git   ·   Translate   ·   Archive   ·   People   ·   Donate
summaryrefslogtreecommitdiffstats
path: root/gst/valve/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'gst/valve/Makefile.am')
-rw-r--r--gst/valve/Makefile.am7
1 files changed, 7 insertions, 0 deletions
diff --git a/gst/valve/Makefile.am b/gst/valve/Makefile.am
new file mode 100644
index 0000000..d7afdc0
--- /dev/null
+++ b/gst/valve/Makefile.am
@@ -0,0 +1,7 @@
+plugin_LTLIBRARIES = libgstvalve.la
+
+libgstvalve_la_SOURCES = gstvalve.c gstvalve.h
+libgstvalve_la_CFLAGS = $(GST_CFLAGS) $(GST_PLUGINS_BASE_CFLAGS) $(ERROR_CFLAGS)
+libgstvalve_la_LIBADD = $(GST_LIBS_LIBS)
+libgstvalve_la_LDFLAGS = $(GST_PLUGIN_LDFLAGS) $(GST_BASE_LIBS) $(GST_PLUGINS_BASE_LIBS)
+libgstvalve_la_LIBTOOLFLAGS = --tag=disable-static