Web   ·   Wiki   ·   Activities   ·   Blog   ·   Lists   ·   Chat   ·   Meeting   ·   Bugs   ·   Git   ·   Translate   ·   Archive   ·   People   ·   Donate
summaryrefslogtreecommitdiffstats
path: root/debian
diff options
context:
space:
mode:
authorGuy Sheffer <guysoft@gmail.com>2008-10-25 16:17:09 (GMT)
committer Marco Pesenti Gritti <mpgritti@gmail.com>2008-10-25 16:56:51 (GMT)
commit419b9727ddd58ce0c18d31c050dc85f1d713415b (patch)
treee288b0e0d9a195780c75abb49791bc66bf37082b /debian
parent399aaa5d97728caac2fab77932a34167e2910fe9 (diff)
Fixed Debian folder, now compiles to prefix /opt/sugar-jhbuild. You will need to be root in order to compile
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog7
-rw-r--r--[-rwxr-xr-x]debian/copyright2
-rwxr-xr-xdebian/rules55
-rw-r--r--debian/sugar-jhbuild-emulator2
4 files changed, 57 insertions, 9 deletions
diff --git a/debian/changelog b/debian/changelog
index 294544a..9b0cbb5 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,10 @@
+sugar-jhbuild (081025-1) unstable; urgency=low
+
+ * Fixed compilation prefix, note that you need to be root now to create the package
+ * Fixed the sugar-jhbuild-emulator bash script
+
+ -- Guy Sheffer <guysoft@gmail.com> Sat, 25 Oct 2008 14:43:21 +0200
+
sugar-jhbuild (081010-1) unstable; urgency=low
* Initial release
diff --git a/debian/copyright b/debian/copyright
index cbd71bc..7602653 100755..100644
--- a/debian/copyright
+++ b/debian/copyright
@@ -1,7 +1,7 @@
This package was debianized by Guy Sheffer <guysoft@gmail.com> on
Sat, 04 Oct 2008 23:06:21 +0300.
-It was downloaded from <url://example.com>
+It was downloaded from http://www.sugarlabs.org/go/LiveCd
Upstream Author(s):
diff --git a/debian/rules b/debian/rules
index 3ac72d9..01dad1f 100755
--- a/debian/rules
+++ b/debian/rules
@@ -9,9 +9,32 @@
# Uncomment this to turn on verbose mode.
#export DH_VERBOSE=1
-
+INSTPATH = /opt/sugar-jhbuild
include /usr/share/dpatch/dpatch.make
+check_root:
+ if test $(USER) != "root" ; \
+ then echo "You must be root in order to build this package" ; exit 1; \
+ fi
+
+link_compile:
+ if test -d $(INSTPATH); then \
+ if test -d $(INSTPATH).real; then \
+ echo "warning: linking seems to have been done alreay" ; \
+ else \
+ echo "linking for compile";\
+ mv $(INSTPATH) $(INSTPATH).real; \
+ ln -s `pwd` $(INSTPATH); \
+ mkdir -p install ; \
+ fi \
+ fi
+
+unlink_compile:
+ if test -d $(INSTPATH).real; then \
+ echo "linking for compile";\
+ rm $(INSTPATH); \
+ mv $(INSTPATH).real $(INSTPATH); \
+ fi
configure: configure-stamp
configure-stamp:
@@ -22,29 +45,47 @@ configure-stamp:
build: build-stamp
-build-stamp: configure-stamp
+build-stamp: configure-stamp check_root link_compile
dh_testdir
# Add here commands to compile the package.
- dpatch apply-all
- export SUGAR_PREFIX=/opt/sugar-jhbuild
- ./sugar-jhbuild build
+ #dpatch apply-all
+
+
+ cd $(INSTPATH) ; pwd ; ./sugar-jhbuild -f debian/sugar.jhbuildrc build
touch build-stamp
-clean:
+ if test -d $(INSTPATH).real; then \
+ echo "linking for compile";\
+ rm $(INSTPATH); \
+ mv $(INSTPATH).real $(INSTPATH); \
+ fi
+
+clean: check_root unlink_compile
dh_testdir
dh_testroot
rm -f build-stamp configure-stamp
- dpatch deapply-all
+ #dpatch deapply-all
+ #if test -d ~/.sugar.jhbuildrc.bak; \
+ # then cp ~/.sugar.jhbuildrc.bak ~/.sugar.jhbuildrc; \
+ #fi
+
dh_clean --exclude ./source/pygobject-2.14.2/gobject/gobjectmodule.c.orig --exclude ./source/telepathy-salut-0.3.3/src/tube-dbus.c.orig --exclude ./source/telepathy-salut-0.3.3/src/tube-stream.c.orig --exclude ./source/mozilla/widget/src/gtk2/nsDragService.cpp.orig --exclude ./source/mozilla/widget/src/gtk2/nsNativeThemeGTK.cpp.orig --exclude ./source/mozilla/netwerk/cache/src/nsDiskCacheDeviceSQL.cpp.orig --exclude ./source/mozilla/netwerk/cache/src/nsDiskCacheMap.cpp.orig --exclude ./source/mozilla/security/nss/lib/softoken/legacydb/keydb.c.orig --exclude ./source/mozilla/security/nss/lib/softoken/legacydb/pcertdb.c.orig --exclude ./source/mozilla/config/rules.mk.orig --exclude ./source/mozilla/modules/plugin/base/src/nsPluginHostImpl.cpp.orig --exclude ./source/mozilla/modules/libpref/src/nsPrefService.cpp.orig --exclude ./source/mozilla/xulrunner/installer/Makefile.in.orig --exclude ./source/mozilla/db/sqlite3/src/sqlite3.c.orig --exclude ./source/abiword-2.6.4/src/af/util/unix/ut_unixAssert.cpp.orig --exclude ./source/telepathy-gabble-0.7.6/src/tube-dbus.c.orig
+
DESTDIR = $(CURDIR)/debian/sugar-jhbuild/opt/sugar-jhbuild/
install: build
dh_testdir
dh_testroot
dh_clean -k --exclude ./source/pygobject-2.14.2/gobject/gobjectmodule.c.orig --exclude ./source/telepathy-salut-0.3.3/src/tube-dbus.c.orig --exclude ./source/telepathy-salut-0.3.3/src/tube-stream.c.orig --exclude ./source/mozilla/widget/src/gtk2/nsDragService.cpp.orig --exclude ./source/mozilla/widget/src/gtk2/nsNativeThemeGTK.cpp.orig --exclude ./source/mozilla/netwerk/cache/src/nsDiskCacheDeviceSQL.cpp.orig --exclude ./source/mozilla/netwerk/cache/src/nsDiskCacheMap.cpp.orig --exclude ./source/mozilla/security/nss/lib/softoken/legacydb/keydb.c.orig --exclude ./source/mozilla/security/nss/lib/softoken/legacydb/pcertdb.c.orig --exclude ./source/mozilla/config/rules.mk.orig --exclude ./source/mozilla/modules/plugin/base/src/nsPluginHostImpl.cpp.orig --exclude ./source/mozilla/modules/libpref/src/nsPrefService.cpp.orig --exclude ./source/mozilla/xulrunner/installer/Makefile.in.orig --exclude ./source/mozilla/db/sqlite3/src/sqlite3.c.orig --exclude ./source/abiword-2.6.4/src/af/util/unix/ut_unixAssert.cpp.orig --exclude ./source/telepathy-gabble-0.7.6/src/tube-dbus.c.orig
dh_installdirs
+
+ #if test -d ~/.sugar.jhbuildrc; \
+ # then cp -a ~/.sugar.jhbuildrc ~/.sugar.jhbuildrc.bak; \
+ #fi
+ #cp -a debian/sugar.jhbuildrc ~/.sugar.jhbuildrc
+
mkdir -p $(DESTDIR)
mkdir -p $(DESTDIR)/install
diff --git a/debian/sugar-jhbuild-emulator b/debian/sugar-jhbuild-emulator
index df7359d..6c356b6 100644
--- a/debian/sugar-jhbuild-emulator
+++ b/debian/sugar-jhbuild-emulator
@@ -1,3 +1,3 @@
-#!/usr/bin/bash
+#!/bin/bash
/opt/sugar-jhbuild/sugar-jhbuild run