Web   ·   Wiki   ·   Activities   ·   Blog   ·   Lists   ·   Chat   ·   Meeting   ·   Bugs   ·   Git   ·   Translate   ·   Archive   ·   People   ·   Donate
summaryrefslogtreecommitdiffstats
path: root/debian
diff options
context:
space:
mode:
authorGuy Sheffer <guysoft@gmail.com>2008-11-03 17:25:43 (GMT)
committer Marco Pesenti Gritti <mpgritti@gmail.com>2008-11-03 17:27:14 (GMT)
commit69f9136afb168792d7b254ef0a1d37eb49746e2a (patch)
tree02ea496d4613e09374aec243281fa6ee0cef3c31 /debian
parent734803b5c91bd1652f97365054e65f5ef03c699e (diff)
More debian prefix fixes, more dependencies and added a script to update changelog.
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog6
-rw-r--r--debian/control2
-rwxr-xr-xdebian/rules13
-rwxr-xr-xdebian/sugar.jhbuildrc1
-rw-r--r--debian/update_changelog12
5 files changed, 29 insertions, 5 deletions
diff --git a/debian/changelog b/debian/changelog
index 9b0cbb5..620f270 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,9 @@
+sugar-jhbuild (081026-1) unstable; urgency=low
+
+ * More prefix tweaking
+
+ -- Guy Sheffer <guysoft@gmail.com> Sat, 25 Oct 2008 14:43:21 +0200
+
sugar-jhbuild (081025-1) unstable; urgency=low
* Fixed compilation prefix, note that you need to be root now to create the package
diff --git a/debian/control b/debian/control
index 0865f44..c5d0fbb 100644
--- a/debian/control
+++ b/debian/control
@@ -8,7 +8,7 @@ Homepage: http://guysoft.wordpress.com
Package: sugar-jhbuild
Architecture: any
-Depends: bash, python, python-gtk2, xorg, xserver-xephyr, python-gnome2-desktop, git
+Depends: bash, python, python-gtk2, xorg, xserver-xephyr, python-gnome2-desktop, git, python-cjson, python-numeric-ext, python-gtksourceview2, espeak, python-vte
#${shlibs:Depends}, ${misc:Depends}, dbus, libavahi-client3, libavahi-common3, libavahi-glib1, libavahi-glib1-2, libdbus-1-3, libdbus-glib-1-2, libxapian15, python-cjson
#Replaces: libdbus-1-3, dbus, libxapian15, libavahi-common3, libavahi-client3, libavahi-glib1, libavahi-glib1-2, libdbus-glib-1-2
Description: Sugar built using jhbuild
diff --git a/debian/rules b/debian/rules
index 01dad1f..1f6df9a 100755
--- a/debian/rules
+++ b/debian/rules
@@ -24,18 +24,23 @@ link_compile:
else \
echo "linking for compile";\
mv $(INSTPATH) $(INSTPATH).real; \
- ln -s `pwd` $(INSTPATH); \
- mkdir -p install ; \
- fi \
+ fi ; \
fi
+ ln -s `pwd` $(INSTPATH);
+ mkdir -p install ;
+
unlink_compile:
+ if test -L $(INSTPATH); then \
+ rm $(INSTPATH); \
+ fi
+
if test -d $(INSTPATH).real; then \
echo "linking for compile";\
- rm $(INSTPATH); \
mv $(INSTPATH).real $(INSTPATH); \
fi
+
configure: configure-stamp
configure-stamp:
dh_testdir
diff --git a/debian/sugar.jhbuildrc b/debian/sugar.jhbuildrc
new file mode 100755
index 0000000..626592e
--- /dev/null
+++ b/debian/sugar.jhbuildrc
@@ -0,0 +1 @@
+prefix = '/opt/sugar-jhbuild/install'
diff --git a/debian/update_changelog b/debian/update_changelog
new file mode 100644
index 0000000..3b33c04
--- /dev/null
+++ b/debian/update_changelog
@@ -0,0 +1,12 @@
+#!/bin/bash
+tmp=`date "+%a, %d %b %Y %T %z"`
+echo "sugar-jhbuild (`date +%G%m%d`-1) unstable; urgency=low
+
+ * Rebuild to new version
+
+ -- Guy Sheffer <guysoft@gmail.com> $tmp
+" > /tmp/sugar_jhbuild
+
+cat /tmp/sugar_jhbuild ./debian/changelog > /tmp/new_change_log
+
+cp /tmp/new_change_log ./debian/changelog