Web   ·   Wiki   ·   Activities   ·   Blog   ·   Lists   ·   Chat   ·   Meeting   ·   Bugs   ·   Git   ·   Translate   ·   Archive   ·   People   ·   Donate
summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMarco Pesenti Gritti <mpg@redhat.com>2007-10-15 13:00:34 (GMT)
committer Marco Pesenti Gritti <mpg@redhat.com>2007-10-15 13:00:34 (GMT)
commit3ddd4be111d74767336a51abcffb2853decf9ca1 (patch)
treeb4b9fe7006c54a495507c81eedb3ff64f3a1f2ef /configure.ac
Initial commit
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac23
1 files changed, 23 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
new file mode 100644
index 0000000..bb55a0a
--- /dev/null
+++ b/configure.ac
@@ -0,0 +1,23 @@
+AC_INIT([sugar-base],[0.1],[],[sugar-base])
+
+AC_PREREQ([2.59])
+
+AC_CONFIG_MACRO_DIR([m4])
+AC_CONFIG_SRCDIR([configure.ac])
+
+AM_INIT_AUTOMAKE([1.9 foreign dist-bzip2 no-dist-gzip])
+
+AC_DISABLE_STATIC
+AC_PROG_LIBTOOL
+
+AM_PATH_PYTHON
+AM_CHECK_PYTHON_HEADERS(,[AC_MSG_ERROR(could not find Python headers)])
+
+AC_PATH_PROG(PYGTK_CODEGEN, pygtk-codegen-2.0, no)
+
+PKG_CHECK_MODULES(EXTENSION, pygobject-2.0)
+
+AC_OUTPUT([
+Makefile
+sugar/Makefile
+])