Web   ·   Wiki   ·   Activities   ·   Blog   ·   Lists   ·   Chat   ·   Meeting   ·   Bugs   ·   Git   ·   Translate   ·   Archive   ·   People   ·   Donate
summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorBruno Coudoin <bcoudoin@src.gnome.org>2005-05-15 14:27:41 (GMT)
committer Bruno Coudoin <bcoudoin@src.gnome.org>2005-05-15 14:27:41 (GMT)
commitca801b4ad1de3e576ca05c3480a15d41d9f9cd56 (patch)
treec67b3c8ee7b933d78acfe56e9d4f1b165e14ac45 /configure.in
parent16302d020164e57d50870328f1ac9cf9139db42d (diff)
updated Added --disable-xrandr option to force xrandr not to be compiledWIN-6_5_3
* TODO: updated * configure.in: Added --disable-xrandr option to force xrandr not to be compiled * src/gcompris/gcompris.c: (board_widget_key_press_callback): new windows code
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in23
1 files changed, 15 insertions, 8 deletions
diff --git a/configure.in b/configure.in
index 2bbb2fe..0495d9f 100644
--- a/configure.in
+++ b/configure.in
@@ -115,19 +115,26 @@ AC_MSG_ERROR([You must have popt 1.5 or newer to compile gcompris.]))
AM_ICONV
dnl XRANDR Allow us to set the screen resolution dynamically
-RANDR_LIBS=
-found_randr=no
-AC_CHECK_LIB(Xrandr, XRRSetScreenConfigAndRate,
+AC_ARG_ENABLE(xrandr,
+ AC_HELP_STRING(
+ [--disable-xrandr],
+ [Turn off xrandr]),
+ USE_XRANDR="$enableval", USE_XRANDR="yes")
+if test "x$USE_XRANDR" == "xyes" ; then
+ RANDR_LIBS=
+ found_randr=no
+ AC_CHECK_LIB(Xrandr, XRRSetScreenConfigAndRate,
[AC_CHECK_HEADER(X11/extensions/Xrandr.h,
RANDR_LIBS="-L/usr/X11R6/lib/ -lXrandr" found_randr=yes,,
[#include <X11/Xlib.h>])],
, -L/usr/X11R6/lib/ -lXrandr $ALL_X_LIBS )
-if test "x$found_randr" = "xno"; then
- AC_MSG_NOTICE(["Suitable Xrandr extension library not found - you need at least X 4.3. Will not use xrandr for fullscreen."])
- AC_DEFINE_UNQUOTED(XRANDR, 0, [XRANDR NOT Available])
-else
- AC_DEFINE_UNQUOTED(XRANDR, 1, [XRANDR Available])
+ if test "x$found_randr" = "xno"; then
+ AC_MSG_NOTICE(["Suitable Xrandr extension library not found - you need at least X 4.3. Will not use xrandr for fullscreen."])
+ AC_DEFINE_UNQUOTED(XRANDR, 0, [XRANDR NOT Available])
+ else
+ AC_DEFINE_UNQUOTED(XRANDR, 1, [XRANDR Available])
+ fi
fi
LDFLAGS="${LDFLAGS} ${RANDR_LIBS}"