Web   ·   Wiki   ·   Activities   ·   Blog   ·   Lists   ·   Chat   ·   Meeting   ·   Bugs   ·   Git   ·   Translate   ·   Archive   ·   People   ·   Donate
summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 7 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 4f1348b..04e1071 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,15 +1,20 @@
AC_PREREQ(2.53)
-AC_INIT([sugar-artwork],[0.86.0],[],[sugar-artwork])
+AC_INIT([sugar-artwork],[0.88.1],[],[sugar-artwork])
AM_CONFIG_HEADER(config.h)
AM_INIT_AUTOMAKE([1.9 foreign dist-bzip2 no-dist-gzip])
+AM_MAINTAINER_MODE
AM_DISABLE_STATIC
PKG_PROG_PKG_CONFIG([0.19])
+dnl These catch plenty of subtle bugs and miscompilation problems
+WARN_CFLAGS="-Wall -W -Werror=implicit-function-declaration"
+AC_SUBST(WARN_CFLAGS)
+
AC_PROG_CC
AC_HEADER_STDC
AC_PROG_LIBTOOL
@@ -20,7 +25,7 @@ if test -z "$ICON_SLICER"; then
fi
PKG_CHECK_MODULES(GTK2, gtk+-2.0 >= 2.0.0,,
- AC_MSG_ERROR([GTK+-2.0 is required to compile redhat-artwork]))
+ AC_MSG_ERROR([GTK+-2.0 is required to compile sugar-artwork]))
GDK_PIXBUF2_CFLAGS=`$PKG_CONFIG --cflags gdk-pixbuf-2.0`
GDK_PIXBUF2_LIBS=`$PKG_CONFIG --libs gdk-pixbuf-2.0`