Web   ·   Wiki   ·   Activities   ·   Blog   ·   Lists   ·   Chat   ·   Meeting   ·   Bugs   ·   Git   ·   Translate   ·   Archive   ·   People   ·   Donate
summaryrefslogtreecommitdiffstats
path: root/schemas/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'schemas/Makefile.am')
-rw-r--r--schemas/Makefile.am20
1 files changed, 20 insertions, 0 deletions
diff --git a/schemas/Makefile.am b/schemas/Makefile.am
new file mode 100644
index 0000000..0614031
--- /dev/null
+++ b/schemas/Makefile.am
@@ -0,0 +1,20 @@
+@INTLTOOL_SCHEMAS_RULE@
+
+schemadir = $(GCONF_SCHEMA_FILE_DIR)
+schema_in_files = sugar.schemas.in
+schema_DATA = $(schema_in_files:.schemas.in=.schemas)
+
+install-data-local: $(schema_DATA)
+if GCONF_SCHEMAS_INSTALL
+ if test -z "$(DESTDIR)" ; then \
+ for p in $^ ; do \
+ GCONF_CONFIG_SOURCE=$(GCONF_SCHEMA_CONFIG_SOURCE) $(GCONFTOOL) --makefile-install-rule $$p 2>&1 > /dev/null; \
+ done \
+ fi
+endif
+
+EXTRA_DIST = \
+ $(schema_in_files)
+
+DISTCLEANFILES = \
+ $(schema_in_files:.schemas.in=.schemas)