Web   ·   Wiki   ·   Activities   ·   Blog   ·   Lists   ·   Chat   ·   Meeting   ·   Bugs   ·   Git   ·   Translate   ·   Archive   ·   People   ·   Donate
summaryrefslogtreecommitdiffstats
path: root/libview/Makefile.am
diff options
context:
space:
mode:
authorCarlos Garcia Campos <carlosgc@gnome.org>2009-01-18 11:53:54 (GMT)
committer Carlos Garcia Campos <carlosgc@src.gnome.org>2009-01-18 11:53:54 (GMT)
commit68d0fc3c59185065d9694ba3f8cb2665b984eb9f (patch)
tree1c3495114d26e1b9d201c557c351d5cf3996f925 /libview/Makefile.am
parent51e1ae36121928f84940b8e8dcb317f87157933b (diff)
Move EvView specific code to a libeviview library so that it can be
2009-01-18 Carlos Garcia Campos <carlosgc@gnome.org> * configure.ac: * Makefile.am: * libdocument/Makefile.am: * libview/Makefile.am: * libview/ev-job-scheduler.[ch]: * libview/ev-jobs.[ch]: * libview/ev-page-cache.[ch]: * libview/ev-pixbuf-cache.[ch]: * libview/ev-timeline.[ch]: * libview/ev-transition-animation.[ch]: * libview/ev-view-accessible.[ch]: * libview/ev-view-marshal.list: * libview/ev-view.[ch]: * shell/Makefile.am: Move EvView specific code to a libeviview library so that it can be embbeded in other applications. Based on patches by Tomeu Vizoso. Fixes bug #567751. svn path=/trunk/; revision=3348
Diffstat (limited to 'libview/Makefile.am')
-rw-r--r--libview/Makefile.am56
1 files changed, 56 insertions, 0 deletions
diff --git a/libview/Makefile.am b/libview/Makefile.am
new file mode 100644
index 0000000..dfdb20e
--- /dev/null
+++ b/libview/Makefile.am
@@ -0,0 +1,56 @@
+INCLUDES= \
+ -DGNOMELOCALEDIR=\"$(datadir)/locale\" \
+ -I$(top_srcdir)/libdocument \
+ $(LIBVIEW_CFLAGS) \
+ $(WARN_CFLAGS) \
+ $(DISABLE_DEPRECATED)
+
+lib_LTLIBRARIES = libevview.la
+
+libevview_la_LDFLAGS = -export-dynamic
+libevview_la_LIBADD = $(LIBVIEW_LIBS)
+
+NOINST_H_FILES = \
+ ev-job-scheduler.h \
+ ev-pixbuf-cache.h \
+ ev-timeline.h \
+ ev-transition-animation.h \
+ ev-view-accessible.h \
+ ev-view-marshal.h \
+ ev-view-private.h
+
+INST_H_FILES = \
+ ev-jobs.h \
+ ev-page-cache.h \
+ ev-view.h
+
+headerdir = $(prefix)/include/evince/@EV_API_VERSION@/ev-view
+header_DATA = $(INST_H_FILES)
+
+libevview_la_SOURCES = \
+ ev-jobs.c \
+ ev-job-scheduler.c \
+ ev-page-cache.c \
+ ev-pixbuf-cache.c \
+ ev-timeline.c \
+ ev-transition-animation.c \
+ ev-view.c \
+ ev-view-accessible.c \
+ ev-view-marshal.c \
+ $(NOINST_H_FILES) \
+ $(INST_H_FILES)
+
+BUILT_SOURCES = \
+ ev-view-marshal.h \
+ ev-view-marshal.c
+
+CLEANFILES = $(BUILT_SOURCES)
+
+ev-view-marshal.h: $(srcdir)/ev-view-marshal.list
+ $(GLIB_GENMARSHAL) --prefix=ev_view_marshal $(srcdir)/ev-view-marshal.list --header > $@
+
+ev-view-marshal.c: $(srcdir)/ev-view-marshal.list
+ echo '#include "ev-view-marshal.h"' > ev-view-marshal.c
+ $(GLIB_GENMARSHAL) --prefix=ev_view_marshal $(srcdir)/ev-view-marshal.list --body >> $@
+
+EXTRA_DIST = ev-view-marshal.list