Web   ·   Wiki   ·   Activities   ·   Blog   ·   Lists   ·   Chat   ·   Meeting   ·   Bugs   ·   Git   ·   Translate   ·   Archive   ·   People   ·   Donate
summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorYves Combe <ycombe@src.gnome.org>2007-03-26 22:04:01 (GMT)
committer Yves Combe <ycombe@src.gnome.org>2007-03-26 22:04:01 (GMT)
commit0c01d5c3e2e040045d8d504f5da869fe2e46a45b (patch)
tree2683e51f3aaff4a316ec111341f791195fa7ed8d /Makefile.am
parent16756441cf594664f10460f6fa82f9ab969ebeda (diff)
add SDL* frameworks copy
svn path=/trunk/; revision=2552
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am14
1 files changed, 10 insertions, 4 deletions
diff --git a/Makefile.am b/Makefile.am
index 245f6b6..20446d9 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -132,7 +132,7 @@ FCT_LDD_CP=function ldd_cp { \
FCT_OTOOL_CP=function otool_cp { \
for f in $$(otool -L $$1 | grep $$2 | eval "sed -e 's,^.*$$2/\(.*.dylib\).*$$,\1,' " ); do \
echo install_name_tool -change $$2/$$f @executable_path$$4/$$f $$1;\
- install_name_tool -change $$2/$$f @executable_path$$4/$$f $$1 ; \
+ install_name_tool -change $$2/$$f @executable_path$$4/$$f $$1 ; \
if test ! -f $$3/$$f ; then \
echo "$(INSTALL) -d $$(dirname $$3/$$f)"; \
echo "$(INSTALL) $$2/$$f $$3/$$f "; \
@@ -184,16 +184,22 @@ endif
for f in $(EXTERN_BIN); do \
$(INSTALL_D) $(prefix)/bin/$$f $(BUNDLE_RESOURCES_DIR)/bin/$$f; \
done
- $(INSTALL) $(top_srcdir)/macosx/Info.plist $(BUNDLE_RESOURCES_DIR)/
- $(INSTALL) $(top_srcdir)/macosx/gcompris.svg $(BUNDLE_RESOURCES_DIR)/
- $(INSTALL) $(top_srcdir)/macosx/gcompris.png $(BUNDLE_RESOURCES_DIR)/
if OS_MACOSX
+ $(INSTALL) $(top_srcdir)/macosx/Info.plist $(BUNDLE_RESOURCES_DIR)/../
+ $(INSTALL) $(top_srcdir)/macosx/PkgInfo $(BUNDLE_RESOURCES_DIR)/../
+ $(INSTALL) $(top_srcdir)/macosx/GCompris.icns $(BUNDLE_RESOURCES_DIR)/
$(FCT_OTOOL_CP) ; for s in $$(find $(BUNDLE_EXEC_DIR)$(NSBUNDLE_GTK_DIR)/ -name '*.so') ; do \
otool_cp $$s $(prefix) $(BUNDLE_EXEC_DIR)$(NSBUNDLE_GTK_DIR) $(NSBUNDLE_GTK_DIR) ; \
done
$(FCT_OTOOL_CP) ; for s in $$(find $(BUNDLE_RESOURCES_DIR) -name '*.so') ; do \
otool_cp $$s $(prefix) $(BUNDLE_EXEC_DIR)$(NSBUNDLE_GTK_DIR) $(NSBUNDLE_GTK_DIR) ; \
done
+ echo WARNING ! I suppose SDL Framewroks installed in /Library/Frameworks
+ $(FCT_CP_TAR); cp_tar /Library/Frameworks/SDL.framework $(BUNDLE_EXEC_DIR)/../Frameworks/SDL.framework
+ $(FCT_CP_TAR); cp_tar /Library/Frameworks/SDL_mixer.framework $(BUNDLE_EXEC_DIR)/../Frameworks/SDL_mixer.framework
+else
+ $(INSTALL) $(top_srcdir)/macosx/gcompris.png $(BUNDLE_RESOURCES_DIR)/
+ $(INSTALL) $(top_srcdir)/macosx/Info-gnustep.plist $(BUNDLE_RESOURCES_DIR)/
endif
endif