Web   ·   Wiki   ·   Activities   ·   Blog   ·   Lists   ·   Chat   ·   Meeting   ·   Bugs   ·   Git   ·   Translate   ·   Archive   ·   People   ·   Donate
summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorYves Combe <ycombe@src.gnome.org>2007-03-19 22:09:39 (GMT)
committer Yves Combe <ycombe@src.gnome.org>2007-03-19 22:09:39 (GMT)
commit05d6c6c5f9fcc43b1b7b73d49cba9f86d16eac8c (patch)
tree29ffe5f7a094850248341f7dbf660034cab2f198 /configure.in
parent26f9d4cd95b27ff0e6e99e63375e4d4273bf439a (diff)
fix compilation problem without nsbundle
svn path=/trunk/; revision=2527
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in20
1 files changed, 15 insertions, 5 deletions
diff --git a/configure.in b/configure.in
index aa35c6b..a4dfe52 100644
--- a/configure.in
+++ b/configure.in
@@ -60,11 +60,11 @@ AC_ARG_ENABLE(nsbundle,
NSBUNDLE_CPPFLAGS=
NSBUNDLE_LDFLAGS=
-_AM_DEPENDENCIES([OBJC])
#check header for nsbundle
if test "x$nsbundle" = "xyes"; then
AC_PROG_OBJC([gcc])
AC_PROG_OBJCPP([gcc])
+
if test "x$native_osx" = "xyes"; then
AC_LANG_PUSH([Objective C])
AC_CHECK_HEADER(Foundation/Foundation.h, NSFoundation="yes" , NSFoundation="no")
@@ -88,8 +88,14 @@ if test "x$nsbundle" = "xyes"; then
NSBUNDLE_LDFLAGS="-rdynamic -fgnu-runtime -L$GNUSTEP_SYSTEM_ROOT/Library/Libraries -lgnustep-base"
AC_LANG_POP([Objective C])
fi
+ AC_DEFINE_UNQUOTED(NSBUNDLE, 1, [ Define to 1 to use NSBundle for relocation (OSX/GNUstep) ])
+else
+OBJC=$CC
+AC_SUBST(OBJC)
fi
+_AM_DEPENDENCIES([OBJC])
+
AC_SUBST(NSBUNDLE_CPPFLAGS)
AC_SUBST(NSBUNDLE_LDFLAGS)
@@ -103,8 +109,6 @@ BUNDLE_NAME="$bundlename"
AC_SUBST(BUNDLE_APPDIR)
AC_SUBST(BUNDLE_NAME)
-AC_DEFINE_UNQUOTED(NSBUNDLE, 1, [ Define to 1 to use NSBundle for relocation (OSX/GNUstep) ])
-
AM_CONDITIONAL(WITH_NSBUNDLE, test "$nsbundle" = yes)
@@ -176,6 +180,12 @@ AM_ICONV
dnl XF86VidMode allows us to set the screen resolution dynamically
AC_PATH_X
+
+XLIBADD=
+if "x$x_libraries" != "x"; then
+ XLIBADD=" -L$x_libraries "
+fi
+
AC_ARG_ENABLE(xf86vidmode,
AC_HELP_STRING(
[--disable-xf86vidmode],
@@ -186,9 +196,9 @@ if test "x$USE_XF86VM" == "xyes" ; then
XF86VM_LIBS=
AC_CHECK_LIB(Xxf86vm, XF86VidModeQueryExtension,
[AC_CHECK_HEADER(X11/extensions/xf86vmode.h,
- XF86VM_LIBS="-L$x_libraries -lXxf86vm" found_xf86vidmode=yes,,
+ XF86VM_LIBS="$XLIBADD -lXxf86vm" found_xf86vidmode=yes,,
[#include <X11/Xlib.h>])],
- , -L$x_libraries $ALL_X_LIBS )
+ , $XLIBADD $ALL_X_LIBS )
if test "x$found_xf86vidmode" = "xno"; then
AC_MSG_NOTICE(["Suitable XF86VidMode extension library not found - Will not use xf86vidmode for fullscreen."])