Web   ·   Wiki   ·   Activities   ·   Blog   ·   Lists   ·   Chat   ·   Meeting   ·   Bugs   ·   Git   ·   Translate   ·   Archive   ·   People   ·   Donate
summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorBruno Coudoin <bruno.coudoin@free.fr>2009-07-17 23:34:17 (GMT)
committer Bruno Coudoin <bruno.coudoin@free.fr>2009-07-17 23:34:17 (GMT)
commit8963c5226c86c5b500f9cdf0638c1cec9b52a592 (patch)
tree4b1fe30a3b5131b0a3ec800058e66cc664d95976 /configure.in
parentf3373a11998b5269a9fbf22ca717a3c33051d059 (diff)
Added support for SDL Mixer audio backend.
The code is taken from the GCOMPRIS 8_3 branch. Now at compilation time we can select the SDL backend or the gstreamer one.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in1
1 files changed, 1 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 91e0f98..a66b932 100644
--- a/configure.in
+++ b/configure.in
@@ -373,6 +373,7 @@ AC_MSG_RESULT($with_sdlmixer)
if test x$with_sdlmixer = xyes; then
PKG_CHECK_MODULES(AUDIO, sdl,, AC_MSG_ERROR([*** SDL Mixer not found!]))
AC_DEFINE([USE_SDLMIXER], 1,[sdl mixer is enabled])
+ AUDIO_LIBS="$AUDIO_LIBS -lSDL_mixer"
else
dnl Default is gstreamer
PKG_CHECK_MODULES(AUDIO, gstreamer-0.10,, AC_MSG_ERROR([*** GSTREAMER not found!]))