Web   ·   Wiki   ·   Activities   ·   Blog   ·   Lists   ·   Chat   ·   Meeting   ·   Bugs   ·   Git   ·   Translate   ·   Archive   ·   People   ·   Donate
summaryrefslogtreecommitdiffstats
path: root/Desktop/dzialo/paste/HelloDoctor.activity/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'Desktop/dzialo/paste/HelloDoctor.activity/setup.py')
-rwxr-xr-xDesktop/dzialo/paste/HelloDoctor.activity/setup.py32
1 files changed, 32 insertions, 0 deletions
diff --git a/Desktop/dzialo/paste/HelloDoctor.activity/setup.py b/Desktop/dzialo/paste/HelloDoctor.activity/setup.py
new file mode 100755
index 0000000..cf647c2
--- /dev/null
+++ b/Desktop/dzialo/paste/HelloDoctor.activity/setup.py
@@ -0,0 +1,32 @@
+#!/usr/bin/env python
+
+# Copyright (C) 2006, Red Hat, Inc.
+#
+# This program is free software; you can redistribute it
+# and/or modify it under the terms of the GNU General
+# Public License as published by the Free Software
+# Foundation; either version 2 of the License, or (at
+# your option) any later version.
+#
+# This program is distributed in the hope that it will
+# be useful, but WITHOUT ANY WARRANTY; without even
+# the implied warranty of MERCHANTABILITY or FITNESS
+# FOR A PARTICULAR PURPOSE. See the GNU General
+# Public License for more details.
+#
+# You should have received a copy of the GNU General
+# Public License along with this program; if not,
+# write to the Free Software Foundation, Inc.,
+# 51 Franklin St, Fifth Floor, Boston, MA
+# 02110-1301 USA
+
+try:
+ from sugar.activity import bundlebuilder
+ bundlebuilder.start()
+except ImportError:
+ import os
+ os.system("find ./ | sed 's,^./,HelloDoctor.activity/,g' > MANIFEST")
+ os.chdir('..')
+ os.system('zip -r HelloDoctor.xo HelloDoctor.activity')
+ os.system('mv HelloDoctor.xo ./HelloDoctor.activity')
+ os.chdir('HelloDoctor.activity')