Web   ·   Wiki   ·   Activities   ·   Blog   ·   Lists   ·   Chat   ·   Meeting   ·   Bugs   ·   Git   ·   Translate   ·   Archive   ·   People   ·   Donate
summaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
authorJonas Smedegaard <dr@jones.dk>2008-05-26 11:50:17 (GMT)
committer Jonas Smedegaard <dr@jones.dk>2008-05-26 11:53:08 (GMT)
commita255363e668b601d326209fed644ca88cd9d2c18 (patch)
treed4da36baf27b4213a030bc703c58ea0492317846 /debian/rules
parentba9faaaa7ac3081971c113d6869c28c92eba4974 (diff)
Tighten (build-)dependency on xulrunner, and rewrite to only declare version number once for both dependency and build-dependencies.
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules8
1 files changed, 7 insertions, 1 deletions
diff --git a/debian/rules b/debian/rules
index a465958..065ec41 100755
--- a/debian/rules
+++ b/debian/rules
@@ -21,8 +21,14 @@ pkg = python-hulahop
# Woraround for type punning causing "size of array 'arg' is negative"
CXXFLAGS += -fno-strict-aliasing
+# Minimum usable version of xulrunner
+python-xpcom-minver = 1.9~rc1
+
+binary-predep/python-hulahop::
+ echo "python-xpcom:Depends=python-xpcom (>= $(python-xpcom-minver))" >> debian/python-hulahop.substvars
+
# Needed by upstream build process
-CDBS_BUILD_DEPENDS := $(CDBS_BUILD_DEPENDS), xulrunner-dev (>= 1.9~b5-4~), python-xpcom (>= 1.9~b5-4~), python-gtk2-dev
+CDBS_BUILD_DEPENDS := $(CDBS_BUILD_DEPENDS), xulrunner-dev (>= $(python-xpcom-minver)), python-xpcom (>= $(python-xpcom-minver)), python-gtk2-dev
# Merge duplicate build-dependencies
CDBS_BUILD_DEPENDS := $(shell echo '$(CDBS_BUILD_DEPENDS)' | sed -e '/\bcdbs (>= 0.4.39)/ s/ *,* *\bcdbs (>= \(0.4.23-1.1\|0.4.27-1\)) *,* */, /g' -e 's/^ *, *//' -e 's/ *, *$$//')