Web   ·   Wiki   ·   Activities   ·   Blog   ·   Lists   ·   Chat   ·   Meeting   ·   Bugs   ·   Git   ·   Translate   ·   Archive   ·   People   ·   Donate
summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMarco Pesenti Gritti <mpg@redhat.com>2007-03-14 13:19:31 (GMT)
committer Marco Pesenti Gritti <mpg@redhat.com>2007-03-14 13:19:31 (GMT)
commit1650ff31114cf38538a95296f717ac76bbcc8f3f (patch)
tree4feb711653d86166559a902f6cae32fe1b79e095 /configure.ac
parent8b4ccf3eb10d0563344e123f7f2c773bba120a2f (diff)
Use nsIWebBrowser conditionally, so that people don't need to patch mozilla.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 10 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index ac02df8..35e67f8 100644
--- a/configure.ac
+++ b/configure.ac
@@ -16,6 +16,16 @@ AM_MAINTAINER_MODE
AC_DISABLE_STATIC
AC_PROG_LIBTOOL
+AC_ARG_ENABLE(ns-web-browser,
+ AC_HELP_STRING([--enable-ns-web-browser],
+ [Enable features which requires access to nsIWebBrowser]),
+ [have_ns_web_browser=yes],
+ [have_ns_web_browser=no])
+
+if test "x$have_ns_web_browser" != "xno"; then
+ AC_DEFINE([HAVE_NS_WEB_BROWSER], [1], ["Have nsIWebBrowser"])
+fi
+
AC_PATH_PROG([GLIB_GENMARSHAL], [glib-genmarshal])
AM_PATH_PYTHON