Web   ·   Wiki   ·   Activities   ·   Blog   ·   Lists   ·   Chat   ·   Meeting   ·   Bugs   ·   Git   ·   Translate   ·   Archive   ·   People   ·   Donate
summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 10 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index ac02df8..35e67f8 100644
--- a/configure.ac
+++ b/configure.ac
@@ -16,6 +16,16 @@ AM_MAINTAINER_MODE
AC_DISABLE_STATIC
AC_PROG_LIBTOOL
+AC_ARG_ENABLE(ns-web-browser,
+ AC_HELP_STRING([--enable-ns-web-browser],
+ [Enable features which requires access to nsIWebBrowser]),
+ [have_ns_web_browser=yes],
+ [have_ns_web_browser=no])
+
+if test "x$have_ns_web_browser" != "xno"; then
+ AC_DEFINE([HAVE_NS_WEB_BROWSER], [1], ["Have nsIWebBrowser"])
+fi
+
AC_PATH_PROG([GLIB_GENMARSHAL], [glib-genmarshal])
AM_PATH_PYTHON